ASRock.com Homepage
Forum Home Forum Home > Media&User's Review > AMD Motherboards
  New Posts New Posts RSS Feed - Issues Installing Microsoft OS
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Issues Installing Microsoft OS

 Post Reply Post Reply
Author
Message
Alik21 View Drop Down
Newbie
Newbie
Avatar

Joined: 03 Apr 2018
Location: Alicante
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alik21 Quote  Post ReplyReply Direct Link To This Post Topic: Issues Installing Microsoft OS
    Posted: 03 Apr 2018 at 10:55pm
I've just bought a new computer with asrock x399 motheboard, AMD Ryzen Threadripper 1950X 3.4GHz and 64GB  DDR4 3000MHz (G. Skill). I've tried to install windows 10 from a USB, and from a DVD and I have the same result: It seems as if the computer is blocked when the Windows logo appear before beginning the installation.
I've installed Ubuntu successfully and everything is running normally.
Anyone knows how to install the win 10?

Thanks in advance
Lo簿c Gu矇rin - CEO Alik21.com
lguerin@alik21.com
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5716
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 03 Apr 2018 at 11:05pm
Make sure you make a fresh install medium using the very latest OS download from Microsoft. This alone eliminates a LOT of issues with AM4 and TR2 systems. 

In addition, always make sure to disconnect all drives from your system except the one you plan to install to. Multiple hard disks/SSDs can cause major installation issues with new hardware. I don't know if this is something Microsoft is working to improve/fix but that has been the case for many users here.
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 5716
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 03 Apr 2018 at 11:07pm
It is especially important to disconnect optical drives. New motherboards and Windows 10 do not play nice with quite a few older optical drives for some reason, often causing major issues with stability and freezing.
Back to Top
Alik21 View Drop Down
Newbie
Newbie
Avatar

Joined: 03 Apr 2018
Location: Alicante
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alik21 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Apr 2018 at 1:09am
I still have issues with the Win10 OS installation. I've read that it seems as if there is a compatibility bug between Asrock wifi module and win10 installation. Anyone knows if that is correct? If it is correct, how can I disable this module for the installation?

Lo簿c Gu矇rin - CEO Alik21.com
lguerin@alik21.com
Back to Top
scythefwd View Drop Down
Newbie
Newbie


Joined: 05 Apr 2018
Status: Offline
Points: 47
Post Options Post Options   Thanks (0) Thanks(0)   Quote scythefwd Quote  Post ReplyReply Direct Link To This Post Posted: 14 Apr 2018 at 1:53am
OK, use the media creation tool on another windows machine, make sure the version you are installing is 1709 or later (that is the latest for now btw).

If that doesnt work, go into the bios and disable iommu and get it installed, then do an update and let the system update to 1709, then you can turn on iommu if need be (or dont if you're not doing virtualization).

I just installed windows 10 my x399 taichi and 1950x about a week ago...

I never disabled the wifi.. matter of fact I have to enable it in the bios (not set to auto) after the fact...

She runs a bit choppy until all the drivers are up to date as well... Then nothing seems to be able to stop her.


Edited by scythefwd - 14 Apr 2018 at 1:54am
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.