ASRock.com Homepage
Forum Home Forum Home > Gaming Zone > Gaming PC Build Advice
  New Posts New Posts RSS Feed - Asrock ab350 pro4 with Ryzen 3 2200g will not boot
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Asrock ab350 pro4 with Ryzen 3 2200g will not boot

 Post Reply Post Reply
Author
Message
Grasshopper View Drop Down
Newbie
Newbie


Joined: 08 Apr 2018
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Grasshopper Quote  Post ReplyReply Direct Link To This Post Topic: Asrock ab350 pro4 with Ryzen 3 2200g will not boot
    Posted: 08 Apr 2018 at 1:55am
Hi all,

I just build my first computer and as a start I went with a budget build and bought myself a Ryzen 3 2200g CPU along with a Asrock AB350 PRo4 MB.

https://ca.pcpartpicker.com/list/Zbf3bX

The build went quite smoothly and everything seems to be compatible on partpicker but for some reason, after I press the power button, there is no video of any sort through the HDMI port. After I double checked everything, I'm starting to suspect that I might need a BIOS update. If that is the case, I could use some advice as I'm a complete beginner regarding pc builds. The MB box has the sticker "AMD Ryzen 2000 Ready", which should be in theory compatible to my processor.

Thanks in advance.

Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Status: Offline
Points: 4768
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 08 Apr 2018 at 3:55am
Try another HDMI cable and make sure your monitor is set to the correct input. If that still gives no display, you can try an HDMI to DVI converter and see if a DVI cable works for you, that or try another display. This is a common problem that is caused by the many HDMI standards and/or cable quality WinkOnboard display outputs tend to be more fussy with cable length and version.

You can also try clearing CMOS, if the cable isn't the issue that usually solves it so do it anyway. If the system is powering on and staying on and the fans speed up and slow down then the BIOS is probably not the issue. 
Back to Top
Devious Donk View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Apr 2018
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote Devious Donk Quote  Post ReplyReply Direct Link To This Post Posted: 10 Apr 2018 at 5:26pm
The Asrock AB350m Pro4 likes to start with just ONE ram stick !

So .....

1. Reset bios 
2. Put ONE ram stick in slot A2 !
3. Update bios to 4.7
4. Install OS
5. Put ram into slot A1 & B1 

PS , make sure nothing is connected , just 24 pin + cpu 8 pin , mouse + keyboard and start button


Edited by Devious Donk - 10 Apr 2018 at 5:28pm
Ryzen 7-1800x / Asrock X370 Killer SLI / Corsair 32Gb 3600Mhz / 2x GTX 1070ti SLI / EVGA 800W psu / X-plane 11 VR with HTC VIVE
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.

This page was generated in 0.047 seconds.