ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - H110m-HDV R3 wont power on
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

H110m-HDV R3 wont power on

 Post Reply Post Reply
Author
Message
Vermingti View Drop Down
Newbie
Newbie
Avatar

Joined: 23 May 2018
Location: UK
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Vermingti Quote  Post ReplyReply Direct Link To This Post Topic: H110m-HDV R3 wont power on
    Posted: 23 May 2018 at 1:34am
Hey guys,

I built a new PC the other day and had it all up and running, I delivered it to where it needed to go, plugged it all in and it wouldn't power on... so took it back home plugged it all in again and the PSU went BANG and blew up... don't know if it was the cable or the PSU... so replaced the PSU and power cable for tried and tested working ones but now the motherboard will not boot... I cannot see any damage to it with my eyes but I am wondering if it is beyond saving ... I know it's supposed to have extra protection on it but it just wont fire up.

I have tried removing the CMOS battery but still after replacing it nothing... any suggestions on if I can get it to fire up (if there is any special way of getting it to start again... I wish there was a CMOS reset jumper on this board) or if I need to get another board?

Thanks!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.063 seconds.