ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - ultrafast boot not working
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

ultrafast boot not working

 Post Reply Post Reply
Author
Message
jbmerrill View Drop Down
Newbie
Newbie
Avatar

Joined: 02 Jan 2018
Location: California
Status: Offline
Points: 103
Post Options Post Options   Thanks (0) Thanks(0)   Quote jbmerrill Quote  Post ReplyReply Direct Link To This Post Topic: ultrafast boot not working
    Posted: 23 May 2018 at 6:16am
[URL=][/URL]Hi,

I have not been able to get ultrafast boot to work on my x399 professional gaming motherboard. I have tried enabling secure boot, and of course disabling csm, and all I get is either a black windows loading screen, or an error that states winload.efi could not be found / loaded, and it just hangs / freezes, at which point I reflash the bios (because I don't want to remove side panel to reach the clear cmos switch).

Has anyone got this working (windows 10), and if so, could you tell me what your config is?

Thanks,

Bryan

Hi, I was finally able to get this to work as follows: enable secure boot, disable csm, enable ultra fast boot, use uefi install of win10, leave dr. debug led disabled, set 1st boot slot to windows boot manager.




Edited by jbmerrill - 28 May 2018 at 7:20am
X399 Pro Gaming, 2990wx Threadripper,128GB G.Skill RGB 3200,EVGA 1200 P2,EVGA GTX 1080 Ti x 2 SLI, Enermax Liqtech 360mm,Samsung 970 EVO/960 Pro/850 EVOs, Toshiba x300 HDDs, Thermaltake Chaser MK-1
Back to Top
Blindegren View Drop Down
Newbie
Newbie


Joined: 25 Jul 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Blindegren Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jul 2018 at 4:03am

Hi, I was finally able to get this to work as follows: enable secure boot, disable csm, enable ultra fast boot, use UEFI install of win10, leave dr. debug led disabled, set 1st boot slot to windows boot manager.


Hello, I also have this problem and I can't find a solution anywhere else, so I was hoping you could help me. In your edit, you said you did the following = 

enable secure boot,- that I can do.

 disable csm,- that I have also done.

 enable ultra-fast boot,- Also that one

 use UEFI install of win10 - This I don't understand can you explain?

 leave dr. debug led disabled, - This I also don't understand

  set 1st boot slot to windows boot manager. The 1st boot slot does not show me "windows boot manager."

Hope you can help me with this :)
Back to Top
gizmic View Drop Down
Groupie
Groupie
Avatar

Joined: 13 Jun 2018
Location: Hong Kong
Status: Offline
Points: 661
Post Options Post Options   Thanks (0) Thanks(0)   Quote gizmic Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jul 2018 at 10:36am
windows key + R (Run) then type msinfo32

look for "Bios Mode" if it says Legacy there is no way you can run on Ultra Fast boot

you have to see if there is a way to convert legacy to uefi windows installation i can imagine they'll be a couple of commands and risk of wiping your windows if you dont know what you're doing 
Back to Top
Blindegren View Drop Down
Newbie
Newbie


Joined: 25 Jul 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Blindegren Quote  Post ReplyReply Direct Link To This Post Posted: 25 Jul 2018 at 6:18pm

Thank you! I see legacy but I know a way to change it to UEFI

what about leave dr. debug led disabled, - what does that mean, and where do i do it 
Back to Top
VUMeter View Drop Down
Newbie
Newbie


Joined: 14 Sep 2017
Location: UK
Status: Offline
Points: 148
Post Options Post Options   Thanks (0) Thanks(0)   Quote VUMeter Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2018 at 3:28am
If you OS is installed in legacy mode I don't think there is a way to 'convert' it to UEFI.  You'll have to reinstall.

For me, I don't think I really notice a difference in boot time between normal and ultrafast boot.  Both take about 25 seconds to get to the desktop and ready to use.
I installed Windows 10 in UEFI mode, and I have ZoneAlarm security, so that could be the culprit in boot/OS launch timing.
X370 TaiChi | 1700X P3.10 stock clocks | (2x 16GB) 32GB FlareX 2400MHz.
Back to Top
gizmic View Drop Down
Groupie
Groupie
Avatar

Joined: 13 Jun 2018
Location: Hong Kong
Status: Offline
Points: 661
Post Options Post Options   Thanks (0) Thanks(0)   Quote gizmic Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2018 at 9:44am
There is a way to convert to uefi windows I?e done it way back I did it because I? using multiple drives in the system and not for fast boot

Fast boot is terrible for me as I? the type who changes OC settings everyday
Back to Top
VUMeter View Drop Down
Newbie
Newbie


Joined: 14 Sep 2017
Location: UK
Status: Offline
Points: 148
Post Options Post Options   Thanks (0) Thanks(0)   Quote VUMeter Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2018 at 7:07pm
I stand corrected.  As gizmic stated, yes there is a way to do it.
My bad, apologies.
X370 TaiChi | 1700X P3.10 stock clocks | (2x 16GB) 32GB FlareX 2400MHz.
Back to Top
jbmerrill View Drop Down
Newbie
Newbie
Avatar

Joined: 02 Jan 2018
Location: California
Status: Offline
Points: 103
Post Options Post Options   Thanks (0) Thanks(0)   Quote jbmerrill Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2018 at 10:10pm
for dr. debug led disable, look for a uefi tab called advanced, then look for an option to change southbridge settings. on my x399 fatal1ty professional, there is a Dr. Debug LED setting for enable, disable. I found it needed to be disabled.

you have to have installed your windows in uefi mode on a gpt disk. Uefi mode is the current method for installing and results in faster/more functional O.S. Since you are in legacy mode, you would need to convert it to uefi, but I have not done that. This also means you must have a motherboard that has uefi bios. I will look into this.

if your boot tab does not have an option for 'windows boot manager' it may be because of legacy mode. Just set your primary hard drive in the first slot.

I tried enabling ultra fast again recently and could not do it, so I don't know what is going on. I will have to try again.


Edited by jbmerrill - 27 Jul 2018 at 10:12pm
X399 Pro Gaming, 2990wx Threadripper,128GB G.Skill RGB 3200,EVGA 1200 P2,EVGA GTX 1080 Ti x 2 SLI, Enermax Liqtech 360mm,Samsung 970 EVO/960 Pro/850 EVOs, Toshiba x300 HDDs, Thermaltake Chaser MK-1
Back to Top
gizmic View Drop Down
Groupie
Groupie
Avatar

Joined: 13 Jun 2018
Location: Hong Kong
Status: Offline
Points: 661
Post Options Post Options   Thanks (0) Thanks(0)   Quote gizmic Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jul 2018 at 2:37pm
Have you convert to uefi mode this includes bios settings and boot drive setting if not fast mode will not work
Back to Top
kodak View Drop Down
Newbie
Newbie


Joined: 05 Jun 2020
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote kodak Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jun 2020 at 3:06pm
I got the same problem with B450M-HDV R4.0. Windows is installed in UEFI mode and the culprit seems to be a GTX970 card which theoretically supports UEFI.
With other card fast boot works fine. With GTX970 I got 5 POST beeps right after I disable CSM. Any ideas?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.