ASRock.com Homepage
Forum Home Forum Home > Media&User's Review > AMD Motherboards
  New Posts New Posts RSS Feed - Asrock Fatal1ty X470 Gaming K4 Review
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Asrock Fatal1ty X470 Gaming K4 Review

 Post Reply Post Reply
Author
Message
ket View Drop Down
Newbie
Newbie


Joined: 13 Jul 2017
Location: UK
Status: Offline
Points: 86
Post Options Post Options   Thanks (0) Thanks(0)   Quote ket Quote  Post ReplyReply Direct Link To This Post Topic: Asrock Fatal1ty X470 Gaming K4 Review
    Posted: 31 Jul 2018 at 7:14pm
Recently I've written a detailed review on the X470 Fatal1ty leaving no stone unturned. You can read this review on win-raid or if you prefer Xtremesystems Enjoy!

I would post the review here but character limitations per post makes putting a direct copy up here more time consuming.


Edited by ket - 12 Sep 2018 at 2:53am
Back to Top
fnordie View Drop Down
Newbie
Newbie


Joined: 22 Jul 2018
Status: Offline
Points: 56
Post Options Post Options   Thanks (0) Thanks(0)   Quote fnordie Quote  Post ReplyReply Direct Link To This Post Posted: 03 Aug 2018 at 2:33pm
thanks nice review!

i have the board.
i aggree that this soundblaster software is a joke, also the realtek windows 10 app that gets installed by default is very lacking in features. this part was the biggest dissapointment about the board. because the sound is the only difference to the cheaper master sli?

if i have a fan installed next to the adressable RGB header, the fan connector is too big, i cann not fit the adressable plug+fan at same time.
fan headers could be placed better imho.

i hope we get long and good UEFI updates!

PS: the xtremesystems link is not working for me, but i loved the forum back in the day!!!


Edited by fnordie - 03 Aug 2018 at 2:38pm
Back to Top
ket View Drop Down
Newbie
Newbie


Joined: 13 Jul 2017
Location: UK
Status: Offline
Points: 86
Post Options Post Options   Thanks (0) Thanks(0)   Quote ket Quote  Post ReplyReply Direct Link To This Post Posted: 12 Sep 2018 at 2:51am
A little late in reply here but thanks for the heads up will fix the XS link not sure why the link for XS is dead. I also just today found the time to port over the X470 review to these forums ;)


Edited by ket - 12 Sep 2018 at 2:53am
Back to Top
el_arantis View Drop Down
Newbie
Newbie


Joined: 14 Dec 2018
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote el_arantis Quote  Post ReplyReply Direct Link To This Post Posted: 14 Dec 2018 at 7:17am
Hello to everyone.
I use the generic Realtek Driver and I need a little help from you.
1st do I need to uninstall SoundBlaster software or no conflicts may occur?
2nd I cannot find options for playback devices, only for recording devices. I used simultaneously audio streams for back and front panel because of head set usage but now this option seems to be missing.
Do I do something wrong?

Thank you in advance for your help!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.046 seconds.