ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Z370 Extreme 4 sound problems after driver update
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Z370 Extreme 4 sound problems after driver update

 Post Reply Post Reply Page  123>
Author
Message
razvan974 View Drop Down
Newbie
Newbie


Joined: 28 Feb 2018
Location: Romania
Status: Offline
Points: 30
Post Options Post Options   Thanks (0) Thanks(0)   Quote razvan974 Quote  Post ReplyReply Direct Link To This Post Topic: Z370 Extreme 4 sound problems after driver update
    Posted: 04 Aug 2018 at 6:30pm
Hello

I want if it possible the older Realtek driver from february 2018 ( Z370Extreme 4). From where i can download it? They test the driver before put an update? Because with updated driver ( from Asrock Z370 Extreme 4 support download) i can tell yolu that the sound it is some sort of crappy distorted sound on all apps, and audio enhacements dissapeared ( including equalizer).

Thanks in advance
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 1786
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 07 Aug 2018 at 11:39am

Dear Razvan974,

 

Thank you for choosing ASRock.

 

About the new Realtek audio driver, you can control by Realtek Audio console app.

After audio driver installed, the Realtek Audio console will be installed automatically.

 


 

Thank you!

Yours truly,

ASRock TSD



Edited by ASRock_TSD - 07 Aug 2018 at 11:40am
Back to Top
razvan974 View Drop Down
Newbie
Newbie


Joined: 28 Feb 2018
Location: Romania
Status: Offline
Points: 30
Post Options Post Options   Thanks (0) Thanks(0)   Quote razvan974 Quote  Post ReplyReply Direct Link To This Post Posted: 11 Aug 2018 at 10:24pm
Almost the same problem. Driver are crap regarding audio quality. Every sound played with every audio player or ingame sound has a lower sound initiallly and after 1 seccond gain rapidly a high volume with higher sound noise. Even when you click on the main sound volume cursor you can hear the difference...

I cannot find anywhere a setting regardin this high variation in volume and noise...

And even when you move the main volume cursor from windows mixer it sound like a bad- defective potentiometer ( old resistor potetiometer that cracks when you try to adjust volume).

UPDATE

This is happened only with headphones exit...




Edited by razvan974 - 11 Aug 2018 at 10:34pm
Back to Top
beo21 View Drop Down
Newbie
Newbie


Joined: 12 Aug 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote beo21 Quote  Post ReplyReply Direct Link To This Post Posted: 12 Aug 2018 at 9:33pm
hi,
same problem here,

latest bios with i7 professional - and only headphones.

cannot use them, at POST Scriptum Game my ears are exploding.

useing also latest realtek driver 8454

please help, with prio bios no problem.

sound istn consumbale anymore

BR
Back to Top
Luppie View Drop Down
Newbie
Newbie


Joined: 13 Aug 2018
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote Luppie Quote  Post ReplyReply Direct Link To This Post Posted: 13 Aug 2018 at 4:35pm
Im not getting DTS interactive surround sound over SPDIF, i see now under speakers DTS but i dont use speaker output. Do i need go back to older drivers for SPDIF surround sound?
Back to Top
razvan974 View Drop Down
Newbie
Newbie


Joined: 28 Feb 2018
Location: Romania
Status: Offline
Points: 30
Post Options Post Options   Thanks (0) Thanks(0)   Quote razvan974 Quote  Post ReplyReply Direct Link To This Post Posted: 14 Aug 2018 at 1:05am
Probably driver itself has some problem with impedance detection for headphones, or is not the right driver for our sound cipset. If i use line exit to an external amplifier, there is no problem with volume.
I reccomend revert to previous version of drivers. Works without problems.

And Asrock - better take out this version from download page...
Back to Top
beo21 View Drop Down
Newbie
Newbie


Joined: 12 Aug 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote beo21 Quote  Post ReplyReply Direct Link To This Post Posted: 16 Aug 2018 at 8:51pm
I took the newer driver version. Directly from realtek and no probs. But the realtek audio software isnt installed ... At least no cracks and headache

Waiting for official new drivers
Back to Top
dacken View Drop Down
Newbie
Newbie
Avatar

Joined: 18 Aug 2018
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote dacken Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2018 at 3:28pm
I have the same issues when using the front audio connector. I only use that one, and have no speaker system because I always use a headset. 

I will download the official realtek ones untill a new ASRock comes out.

Download R2.82 from the official realtek site. http://www.realtek.com.tw/downloads/downloadsCheck.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

Realtek Audio Console app does not work, unfortunately. :(



Edited by dacken - 18 Aug 2018 at 3:36pm
Back to Top
Artimid View Drop Down
Newbie
Newbie


Joined: 01 Sep 2018
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote Artimid Quote  Post ReplyReply Direct Link To This Post Posted: 01 Sep 2018 at 11:29pm
I'll try those drivers again from Realtek (their download is soooo slow.. like 7 hours to download them, slow), but my mic also can't be heard now unless at 100 with full boost. I am plugged into the back for the mic, but front or back has this.

It is quite horrible.
Back to Top
razvan974 View Drop Down
Newbie
Newbie


Joined: 28 Feb 2018
Location: Romania
Status: Offline
Points: 30
Post Options Post Options   Thanks (0) Thanks(0)   Quote razvan974 Quote  Post ReplyReply Direct Link To This Post Posted: 02 Sep 2018 at 3:37am
How it is possible to take out from download page good audio drivers and put in place a damaged ones and pretend that nothing happened? The situation now look like this...

And i think that after you put damaged drivers on download page, in 24 hour you must resolve the situation in a way or another - take out and put back the older drivers, or repair the bug with the new one.

Asrock what's the problem? A similar situation - unresolved situation is with memory compatibility too. You have on forums hundreds of ppl with problem but you do nothing in order to resolve problems.  3 new UEFI version and the problem with higher Vccio voltage ( for some ppl) is still unresolved( in over than six months). Next time when i want to buy somethink from you i will think twice and probably i will go with other brand. I am shure i will not be alone with this decision...
Back to Top
 Post Reply Post Reply Page  123>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.