ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Fatal1ty B450 Gaming K4 - Fan Control doesn't work
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Fatal1ty B450 Gaming K4 - Fan Control doesn't work

 Post Reply Post Reply Page  <123>
Author
Message
fnordie View Drop Down
Newbie
Newbie


Joined: 22 Jul 2018
Status: Offline
Points: 54
Post Options Post Options   Thanks (0) Thanks(0)   Quote fnordie Quote  Post ReplyReply Direct Link To This Post Posted: 28 Oct 2018 at 5:50pm
how much longer will it take to fix this simple bug? also why are XFR and PBO fine tuning like MSI has? 

i hope people stop buying asrock stuff
Back to Top
shindig View Drop Down
Newbie
Newbie


Joined: 12 Nov 2018
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote shindig Quote  Post ReplyReply Direct Link To This Post Posted: 12 Nov 2018 at 4:37am
Hey all. 

Quick question about fan control on the B450 boards. When using Tctl as temperature source, won't the fans annoyingly keep ramping up/down rapidly to match spiking Tctl temperatures? Or is there a hysteresis or step up/down feature I'm just not seeing?


Edited by shindig - 12 Nov 2018 at 4:43am
Back to Top
fnordie View Drop Down
Newbie
Newbie


Joined: 22 Jul 2018
Status: Offline
Points: 54
Post Options Post Options   Thanks (0) Thanks(0)   Quote fnordie Quote  Post ReplyReply Direct Link To This Post Posted: 12 Nov 2018 at 5:16pm
i think all asrock boards (am4) use the same fan controlls?

the ramp up is very noticeable, i try to set the temps beyond the spikes. but this is still a compromise. and still very noticeable with the quick fan speed changes.

i think we only can set the curve. no step up hor hysteresis.

i wonder whats up with the sensor in the socket. why is it disabled on almost all asrock boards? is it broken fom the factory? or maybe its just the core temp +  smoothing?
Back to Top
Miepel View Drop Down
Newbie
Newbie


Joined: 13 Nov 2018
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote Miepel Quote  Post ReplyReply Direct Link To This Post Posted: 13 Nov 2018 at 2:54am
My B450M Pro4 has many issues:
- Fan control does not work with MB sensor.
- Fan speed changes rapidly when using CPU sensor.
- Strange counts of the other sensors (VRM Mos and VSoC very high and do not vary).
- Coil whine of the MB while heavy load on GPU.
I read the sensors with HW-Info (latest version).
This is very annoying. I replaced a Gigabyte GA-AB350, because I wanted to control 5 fans separately. The Gigabyte MB had only 3 fan headers, but the fan control worked very nice.
Again, very annoying.
Miepel
PS: Please excuse my poor English.

Back to Top
fnordie View Drop Down
Newbie
Newbie


Joined: 22 Jul 2018
Status: Offline
Points: 54
Post Options Post Options   Thanks (0) Thanks(0)   Quote fnordie Quote  Post ReplyReply Direct Link To This Post Posted: 15 Nov 2018 at 4:14pm
i see a new 1.5 bios update for the Fatal1ty B450 Gaming K4. someone try this allready? thanks
Back to Top
fnordie View Drop Down
Newbie
Newbie


Joined: 22 Jul 2018
Status: Offline
Points: 54
Post Options Post Options   Thanks (0) Thanks(0)   Quote fnordie Quote  Post ReplyReply Direct Link To This Post Posted: 15 Nov 2018 at 4:45pm
sorry i meant the x470 fatality k4 got the update.

i just installed it. but the fan problem is still there
Back to Top
Miepel View Drop Down
Newbie
Newbie


Joined: 13 Nov 2018
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote Miepel Quote  Post ReplyReply Direct Link To This Post Posted: 16 Nov 2018 at 12:48am
I have updated to 1.50 and then to 1.60 (latest ASRock Bios). Still no difference.
Back to Top
basedmeezus View Drop Down
Newbie
Newbie


Joined: 13 Oct 2018
Status: Offline
Points: 68
Post Options Post Options   Thanks (0) Thanks(0)   Quote basedmeezus Quote  Post ReplyReply Direct Link To This Post Posted: 17 Nov 2018 at 7:15am
so for my pc case fans, should i set that to tctl as well? or keep it at mobo or cpu?

Thanks
Back to Top
Miepel View Drop Down
Newbie
Newbie


Joined: 13 Nov 2018
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote Miepel Quote  Post ReplyReply Direct Link To This Post Posted: 18 Nov 2018 at 6:11pm
TCtl seems to be the only value, that works with the fan control. So I've connected all fans to TCtl.
There is an option for temperature hysteresis (AMD CBS/MBIO/Fan control). It is possible to set it between 0 and 255, but I didn't recognized any difference.
Back to Top
globsch View Drop Down
Newbie
Newbie


Joined: 18 Nov 2018
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote globsch Quote  Post ReplyReply Direct Link To This Post Posted: 18 Nov 2018 at 10:13pm
ASRock B450 Pro 4 here.

Same Problem. Very glad to find this thread. Was ready to send the Board to RMA and buy anoter one.

I think there are many users who regognize these problems and than try another Manufacturer.

Asrock should fix it. Monitor CPU has no effect. tried Bios 1.4 and 1.5.
till today I cant confirm that monitor MB works.
Back to Top
 Post Reply Post Reply Page  <123>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.090 seconds.