ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Intel Quad Gigabit PCIe in J4105B-ITX?
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Intel Quad Gigabit PCIe in J4105B-ITX?

 Post Reply Post Reply
Author
Message
fmyhr View Drop Down
Newbie
Newbie


Joined: 09 Oct 2018
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote fmyhr Quote  Post ReplyReply Direct Link To This Post Topic: Intel Quad Gigabit PCIe in J4105B-ITX?
    Posted: 09 Oct 2018 at 4:08am
Hi,

I'm trying to get an Intel I350-T4 quad gigabit ethernet PCIe card to work in my J4105B-ITX, BIOS 1.30. This PCIe card has been working fine in my ASRock J3455M 1.80 motherboard. But when I install it in the J4105B-ITX, the system fails to POST: no HDMI video, front-panel power button doesn't work. I have to kill power at the wall. I've tried various BIOS settings, none have helped. The board *does* boot normally with an Intel Pro/1000 PT PCIe installed, so its PCIe slot is functional with some cards -- but not with the card I need.

If anyone has an Intel quad-port gigabit PCIe card working in a J4105B-ITX, it would be *awesome* if you'd report your recipe for success. I suspect a BIOS update may be needed.

At least one Newegg reviewer reports success using a J3455B-ITX. I may have to revert to using this older board if I can't get it working with the J4105.

Thanks,
Frank

P.S.
I see on the ASRock support website that sister model J4105-ITX has newer BIOS 1.30B and 1.40 that improve WiFi card compatibility and update microcode, while J4105B-ITX does not get these fixes yet.
Back to Top
fmyhr View Drop Down
Newbie
Newbie


Joined: 09 Oct 2018
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote fmyhr Quote  Post ReplyReply Direct Link To This Post Posted: 17 Oct 2018 at 10:23pm
An update:

Using a thin strip of electrical tape to mask PCIe pins B5 & B6 as described here:


allows the J4105B-ITX to boot normally with the i350-T4 (Dell THGMP variant) quad ethernet card installed. I'm using BIOS L1.33 that ASRock tech support sent me, but this hack probably works for standard P1.30 BIOS as well (since L1.33 alone didn't fix the problem).

Masking pins B5 & B6 cuts off SMBUS signaling between motherboard and PCIe card. This disables i350 temperature reporting, likely prevents i350 firmware updates, and possibly causes other problems as well. So I'm still hoping that ASRock can update J4105B-ITX BIOS to make this hack unnecessary -- as it is on J3455M with 1.80 BIOS.






Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.