Print Page | Close Window

Running HyperX Predator at 3200MHz on B450 Pro4

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=9744
Printed Date: 09 May 2021 at 10:37am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Running HyperX Predator at 3200MHz on B450 Pro4
Posted By: jenson87
Subject: Running HyperX Predator at 3200MHz on B450 Pro4
Date Posted: 23 Sep 2018 at 12:54am

Hey!


Two days ago I built my rig and everything was going great until I noticed that my ram was only running at 2400MHz. First both XMP profiles (3200/3000MHz) failed to boot even after adjusting the voltage a little bit. But even for ~2600MHz I couldn't get the system to boot. 


This is the link to my build:  https://de.pcpartpicker.com/list/YyDCCb" rel="nofollow - https://de.pcpartpicker.com/list/YyDCCb

This is the data sheet of my ram kit:  https://www.kingston.com/dataSheets/HX432C16PB3K2_16.pdf" rel="nofollow - https://www.kingston.com/dataSheets/HX432C16PB3K2_16.pdf

Also it is featured in the list of ryzen compatible kits:  https://media.kingston.com/pdfs/hx-product-memory-ddr4-amd-ryzen-and-hx-compatibility-en.pdf" rel="nofollow - https://media.kingston.com/pdfs/hx-product-memory-ddr4-amd-ryzen-and-hx-compatibility-en.pdf


Both modules together run on the "default" values at 2400MHz without a problem. Also both modules seem to run in single use (using the A2 slot on the board) at 3200MHz using the XMP profile or even custom timings I got through Thaiphoon Burner and entered manually in the BIOS. But every time I put both of the modules in while using anything besides defaults (2400MHz) I never even get to the ASRock logo before it crashes.


In this context I I realized that the exact kit isn't listed under "QVL Memory" for the B450 Pro4 at ASRock:  https://www.asrock.com/mb/AMD/B450%20Pro4/index.asp#Memory" rel="nofollow - https://www.asrock.com/mb/AMD/B450%20Pro4/index.asp#Memory


Is this simply the reason I can't get these to work or is there another workaround I could try?


Appreciate every bit of help. Thanks in advance!




Replies:
Posted By: xhue
Date Posted: 23 Sep 2018 at 1:39am
Flash the latest BIOS. Clear CMOS, reboot.

Select just the XMP with the 2 sticks and see what happens. If it fails again, try bumping SoC voltage a bit to 1.15V or 1.2V. Try boosting RAM voltage too.


Posted By: jenson87
Date Posted: 23 Sep 2018 at 3:00am
Hey!

I made sure that I was running the latest BIOS version before I changed anything in the BIOS and also already tried adjusting SoC and RAM voltage with no real success. 

But I went for a Clear CMOS anyway because after setting manual timing and a bunch of failed boot attempts all of my case fans stopped working while the CPU cooler went way louder than before. At least this is back to normal after a quick reset. No progress on the ram kit though.


Posted By: xhue
Date Posted: 23 Sep 2018 at 7:46pm
My say is you'll have tough times getting the RAM @ 3200MT/s. Getting there and staying stable are 2 separate things.

With Ryzen Gen.1 it's a bad thing to shop outside QVL. If I was you I'd choose 1 of these 2 options: run the RAM @ JEDEC default, i.e. 2400MT/s; get a 3200 kit from the QVL. It all boils down to what you need and what you can afford.


Posted By: jenson87
Date Posted: 23 Sep 2018 at 10:55pm
" rel="nofollow - Yeah, that seems to be the only reasonable way forward. But checking QVL lists isn't as straightforward as I imagined either. For example I came across this CL14 3200MHz kit from Team Group for a good price:
http://www.teamgroupinc.com/en/product/dark-pro-ddr4" rel="nofollow - https://www.teamgroupinc.com/en/product/dark-pro-ddr4

According to its QVL (which seems to be for the whole series of kits) it should run at 3000MHz on B450 Pro4: 
http://www.teamgroupinc.com/en/catalog/act.php%3Fact=1&index_id=71" rel="nofollow - https://www.teamgroupinc.com/en/catalog/act.php?act=1&index_id=71

But at the same time it's not listed at ASRock's B450 Pro4 QVL:
http://www.asrock.com/mb/AMD/B450%20Pro4/index.asp#Memory" rel="nofollow - https://www.asrock.com/mb/AMD/B450%20Pro4/index.asp#Memory

So has anyone experience on what I could expect from this kit on this specific board? Running stable 3000MHz would be alright with me but I want to make sure that I'm not running into incompatibility issues again.


Posted By: jenson87
Date Posted: 23 Sep 2018 at 11:19pm
" rel="nofollow - What I forgot in my previous post:
I have a Ryzen 7 2700 on a B450 Board... so that makes it all "Gen.2", right?


Posted By: Reinvented
Date Posted: 24 Sep 2018 at 2:47am
Most of the kits on QVL's are for just saying "yeah, I can run it using XMP profiles".  Your kit will run fine, but requires a bit of input with manual timings/adjustments.  Use Ryzen DRAM Calculator and Taiphoon Burner to get a baseline before tweaking.  


Posted By: jenson87
Date Posted: 24 Sep 2018 at 3:20am
" rel="nofollow - I tried exactly this with the HyperX kit and the result was pretty much the same as when using the XMP profiles: Individually (as in solo usage in A2) both modules ran at 3000/3200MHz but as soon as I put the second module in it fails to boot and resets the kit to 2400MHz.

I read somewhere that a faulty CPU (e.g. broken pins) could be the issue here as well. I bought my 2700 used and so far it seems to run perfectly normal out of the box. 

I also just realized that there are only 8GB usable in the Windows 10 task manager. It shows 16GB in the top right but right now for example 3,6/7,9GB (46%) are in use.

My question is: Where do these problems generally point to? Problems with the board, the CPU or the kit? I just don't want to buy another kit to have the same problems again.

Thanks a lot!


Posted By: Reinvented
Date Posted: 24 Sep 2018 at 3:37am
I don't understand why you'd have to buy another kit at all.  Send it off for RMA if it's faulty.  Same with any other components.  

If the CPU is the problem, you'd need to inspect it.  Or again, play the RMA game.  


Posted By: xhue
Date Posted: 24 Sep 2018 at 3:49am
Originally posted by jenson87 jenson87 wrote:

I have a Ryzen 7 2700 on a B450 Board... so that makes it all "Gen.2", right?


Yep, that's Gen.2 (or second iteration, or whatever they call it Tongue) Ryzen right there. It has way more advanced IMC, so running more memories and speeds it expected, compared to Gen.1

Some manufacturers are using different memory dies (chips) for the same part number, so some of them might end up crazy in the QVL.

It all boils down to what you want. If you want a stable and straightforward approach - go for the QVL. If you so desire tweaking and knowledge - get some other kit and play with it.


Posted By: jenson87
Date Posted: 24 Sep 2018 at 4:17am
Well, my problem is that I don't know which of the components (RAM, CPU or board) is the culprit here which is why I would greatly appreciate any hints on how to tell where to start the process.

I already submitted a ticket to ASRock and will the check the CPU for broken/bent pins tomorrow.


Posted By: Reinvented
Date Posted: 24 Sep 2018 at 7:27am
We can't tell you either.  You have to test them.  Or just RMA them. 


Posted By: xhue
Date Posted: 24 Sep 2018 at 7:31am
Oh, my. Me and my reading... Tongue

Well, sticks being able to run 3200 solo is a good indication that RAM is probably OK.

PC not being able to POST with high mem clocks means that memory can't be 'trained'. Why? IDK yet.

For starters, memtest the sh*t out of each RAM stick alone, when running at 3200. Throw in a bunch of other benchmarks too. If both sticks pass with flying colors then the issue is elsewhere.

Bent CPU pins would manifest in many other ways.

Better see if you can borrow another CPU from a friend or something.

P.S. always clear CMOS before each reconfig. Touch only XMP & fans in BIOS. Leave the rest alone for now.


Posted By: jenson87
Date Posted: 24 Sep 2018 at 6:07pm
" rel="nofollow -
Hey xhue, thanks for the input!

Yeah, it might be a good idea to thoroughly test the modules. So far I just made sure they were able to boot into windows because in dual use above 2400MHz it always failed right away.

The reason I'm being a little sceptical about the CPU is that it was the only component I bought in used condition. I visually checked the CPU and didn't notice anything out of the ordinary thoughs.

I'm still no sure how to check if the board (specifically the RAM slots) is the problem though. For using just one module im supposed to use the A2 slot and for dual use A2/B2. Should I be able to boot with one kit on B2 with an 3200MHz XMP profile? What about the A1/B1 slots?






Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net