ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Bricked Z390 Phantom Gaming itx
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Bricked Z390 Phantom Gaming itx

 Post Reply Post Reply
Author
Message
Alberto View Drop Down
Newbie
Newbie
Avatar

Joined: 06 Nov 2018
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Alberto Quote  Post ReplyReply Direct Link To This Post Topic: Bricked Z390 Phantom Gaming itx
    Posted: 06 Nov 2018 at 5:26am
Hi,
my new rig is an 8700k with 32gb ram tridentz 3200mhz and 2 nve 500gb ssd running ubuntu 18.10.
I updated the bios to the latest version and worked well
I enabled the onboard graphics as I am not running discrete as I use the machine for development.
Was trying to set up the ram to 3200mhz (board recognized as 2600) in the bios.
Rebooted and now I have a black screen. All fans are working and memory lights up but no video output and no post (numlock off). Tried removing ram and resetting CMOS (power off, remove battery, push reset cmos at back a gazillion times). Nothing works... 
Do I need a new mobo? Any other suggestions?
Customer support had me try 5 cmos button push then said return the motherboard......   


Edited by Alberto - 06 Nov 2018 at 8:46am
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.187 seconds.