ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Motherboard won't post/Flashing White light
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Motherboard won't post/Flashing White light

 Post Reply Post Reply
Author
Message Reverse Sort Order
naarv View Drop Down
Newbie
Newbie


Joined: 23 Sep 2021
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote naarv Quote  Post ReplyReply Direct Link To This Post Topic: Motherboard won't post/Flashing White light
    Posted: 23 Sep 2021 at 2:58pm
Hey so my PC randomly crashed and I'm getting the same flashing lights and it won't post. How did you manage to fix it? Thanks.
Back to Top
xhue View Drop Down
Groupie
Groupie


Joined: 17 Aug 2018
Status: Offline
Points: 634
Post Options Post Options   Thanks (0) Thanks(0)   Quote xhue Quote  Post ReplyReply Direct Link To This Post Posted: 06 Jan 2019 at 9:39pm
Try taking out 1 stick of RAM. Take out the PSU 230V/110V cable, take out the button cell battery (CMOS one). Press power on button for 15 sec.

Put the battery back in, plug in the power cord in the PSU. Try booting again.

If this doesn't help, I'm afraid you may need another mobo.

P.S. Oh, my! BIOS v3.00?!?! This version doesn't support Ryzen 2! You need v4.50 or later for that CPU!
Back to Top
Acovarru91 View Drop Down
Newbie
Newbie
Avatar

Joined: 06 Jan 2019
Location: US
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote Acovarru91 Quote  Post ReplyReply Direct Link To This Post Posted: 06 Jan 2019 at 10:50am
I updated my asrock x370 killer sli to version 3.0 via the BIOS install and after it "successfully" installed, my motherboard won't post. There is a flashing white light blinking underneath my chipset and no information online tells me what that means. All my hardware was working prior to the update and here is a list of my hardware:
Asrock x370 killer sli
Evga GTX 1070
Corsair Vengeance LPX
AMD Ryzen 2700x
OCZ Fatality 750W

I have reseated my CPU, ram, and although not recommended after updating, cleared CMOS.
If I could figure out what to do that would save some work and headaches.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.172 seconds.