ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Ryzen 3000 series support
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Ryzen 3000 series support

 Post Reply Post Reply Page  <1 4041424344 108>
Author
Message
bep1995 View Drop Down
Newbie
Newbie
Avatar

Joined: 26 Sep 2019
Location: Greece
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote bep1995 Quote  Post ReplyReply Direct Link To This Post Posted: 26 Sep 2019 at 8:31pm
So, I should download drivers from asrock only if I have apu live ryzen 3 2200g otherwise can I download these drivers
https://www.amd.com/en/support/chipsets/amd-socket-am4/b450
and these drivers (with chipset drivers box unchecked)
https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-560

Right ??
Back to Top
sajmon83 View Drop Down
Newbie
Newbie
Avatar

Joined: 24 Sep 2019
Location: Poland
Status: Offline
Points: 21
Post Options Post Options   Thanks (0) Thanks(0)   Quote sajmon83 Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2019 at 12:38am
Originally posted by bep1995 bep1995 wrote:

So, I should download drivers from asrock only if I have apu live ryzen 3 2200g otherwise can I download these drivers
https://www.amd.com/en/support/chipsets/amd-socket-am4/b450
and these drivers (with chipset drivers box unchecked)
https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-560

Right ??

That's right
MB: ASRock X470 Taichi (L3.71)
CPU: Ryzen 7 3700X
RAM: 2xG-Skill FlareX F4-3200C14-8GFX @ 3600CL14 MHz
GPU: Gigabyte GTX 1080 TI @ C2025 MHz M6003 MHz
M.2 256GB SSD 512GB HDD 2TB+3TB
Back to Top
bep1995 View Drop Down
Newbie
Newbie
Avatar

Joined: 26 Sep 2019
Location: Greece
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote bep1995 Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2019 at 1:04am
Ok, I understand, but why asrock didn't clarified that ?? what if someone with nvidia gpu try to install amd all in one drivers ?? can this be done ?? Current chipset drivers version is 1.8.19.0915 and asrock says it must be 18.50.16.01 to do bios update. Am I the only one who confused ??
Back to Top
sajmon83 View Drop Down
Newbie
Newbie
Avatar

Joined: 24 Sep 2019
Location: Poland
Status: Offline
Points: 21
Post Options Post Options   Thanks (1) Thanks(1)   Quote sajmon83 Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2019 at 5:23am
Oh man xD If anyone installs amd all in 1 it doesn't matter. Only the drivers that can be installed are installed. So if you don't have a GPU from AMD then only the chipset drivers will be installed. As for the numbering I'm not sure but they are probably two separate numbers. I think I have explained everything else to you before

Edit
I compared the two versions and, as I thought, they are two separate numbers. You can compare it yourself in the screenshot. AMD Chipset Drivers v1.8.19.0915 are newer and fresher



+ Newer
= Same
- Older
MB: ASRock X470 Taichi (L3.71)
CPU: Ryzen 7 3700X
RAM: 2xG-Skill FlareX F4-3200C14-8GFX @ 3600CL14 MHz
GPU: Gigabyte GTX 1080 TI @ C2025 MHz M6003 MHz
M.2 256GB SSD 512GB HDD 2TB+3TB
Back to Top
bep1995 View Drop Down
Newbie
Newbie
Avatar

Joined: 26 Sep 2019
Location: Greece
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote bep1995 Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2019 at 5:43am
Thank you man !!! I appreciate it !! My mainly question is if i can have separate drivers for chipset and gpu and if this works to do bios update to install ryzen 3000 since asrock says i must have drivers version 18.50.16.01 or newer

PS I. How can i install radeon/all in one drivers without chipset drivers, which boxes must have uncheked at installation ??
PS II. What's the different from all in one drivers and the radeon/amd drivers from amd.com ??

Sorry for that questions, but i am very confused.
Back to Top
sajmon83 View Drop Down
Newbie
Newbie
Avatar

Joined: 24 Sep 2019
Location: Poland
Status: Offline
Points: 21
Post Options Post Options   Thanks (0) Thanks(0)   Quote sajmon83 Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2019 at 6:03am
Really xD?
Answer to PSI and PSII: AMD all in one are a combination of AMD Chipset Drivers (some version) with Adrenalin GPU drivers (some version)
So download and install AMD Chipset Drivers 1.8.19.0915 then download Adrenalin 2019 Edition 19.9.2 and then you have the latest drivers for the chipset and Graphics.
Installing All in One will install the chipset and Graphics but some older versions of these drivers. These two drivers together
have separate numbering. The name itself tells you ALL IN ONE
MB: ASRock X470 Taichi (L3.71)
CPU: Ryzen 7 3700X
RAM: 2xG-Skill FlareX F4-3200C14-8GFX @ 3600CL14 MHz
GPU: Gigabyte GTX 1080 TI @ C2025 MHz M6003 MHz
M.2 256GB SSD 512GB HDD 2TB+3TB
Back to Top
bep1995 View Drop Down
Newbie
Newbie
Avatar

Joined: 26 Sep 2019
Location: Greece
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote bep1995 Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2019 at 6:18am
Ok !! Thank you man for your time to answer my questions !! I will see what to do.. I think i have no more questions..... for now... :p
Back to Top
mcgstar View Drop Down
Newbie
Newbie


Joined: 27 Sep 2019
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote mcgstar Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2019 at 7:00am
Hi! Can someone point me to a beta BIOS with ECC support on X470 Taichi? I heard about 3.62 on Reddit, but I've searched few hours on the forum, no luck.
Thanks
Back to Top
skavan View Drop Down
Newbie
Newbie


Joined: 19 Oct 2018
Location: CT
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote skavan Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2019 at 10:13am
Hi,

Just built a rig on the new x570 Creator.
Primary reason was the Thunderbolt support - but I can't get it functioning properly.
So - system:
- 3900x CPU
- RTX 2080 Ti GPU
- 64GB Ram (Corsair)
- x570 Creator
- LG 34WK95U-W 34" 5K Thunderbolt Display (with USB Hub)

I run the displayport cable out of the RTX 2080 Ti and into the displayport in of the Mobo Backpanel. Then the Thunderbolt cable from TB on Mobo Backpanel to Monitor.

Two problems:


  1. TB Connection won;t drive monitor at 5K (5120x2160). Direct DisplayPort to Monitor connection works fine.
  2. TB sees the USB Hub on the monitor, but then reports an error with the USB device.


So - am running latest asrock bios and drivers from web site. So stuck.
Appreciate any advice I can get.
Back to Top
Distortion View Drop Down
Newbie
Newbie


Joined: 15 Sep 2019
Location: Finland
Status: Offline
Points: 11
Post Options Post Options   Thanks (1) Thanks(1)   Quote Distortion Quote  Post ReplyReply Direct Link To This Post Posted: 27 Sep 2019 at 5:39pm
HereĀ“s a link from the Reddit topic:

http://www.mediafire.com/file/tk4uy0vkic6ae8a/X470TC_3.62.zip/file
Back to Top
 Post Reply Post Reply Page  <1 4041424344 108>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.094 seconds.