ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Bios not detecting USB with Windows
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Bios not detecting USB with Windows

 Post Reply Post Reply
Author
Message
dannykujo View Drop Down
Newbie
Newbie


Joined: 25 Apr 2020
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote dannykujo Quote  Post ReplyReply Direct Link To This Post Topic: Bios not detecting USB with Windows
    Posted: 25 Apr 2020 at 10:02am
I recently installed the media creation tool at the Microsoft website. Before doing this, I formatted the USB to FAT32. I plugged in the USB to every port including the Mobo and front ports. It does not appear in the boot options when I get into bios. I am basically stuck since I can't install the OS to my newly built pc.

Mobo: Asrock B450m Pro4
Back to Top
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 3139
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 25 Apr 2020 at 10:08am
my wife has this very same motherboard

it should just automatically boot from the usb when it dosnt see an o/s on hdd

reset bios to defaults
place a formatted hdd/sdd in sata or nvme and switch it on
the default bios settings should look for hdd and then go to usb drive

i would also retry to make the usb drive with a fresh copy of windows media creation (it might have corrupt bootable files)
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold
Back to Top
dannykujo View Drop Down
Newbie
Newbie


Joined: 25 Apr 2020
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote dannykujo Quote  Post ReplyReply Direct Link To This Post Posted: 25 Apr 2020 at 10:51am
I just reset the bios to defaults. I also did a new windows creation tool as well. Formatted it the usb the same way (fat32). Turned on my pc and it didn't boot automatically. Checked in bios and only my nvme m.2 ssd shows up. Its the only boot option appear. Not sure what I did wrong
Back to Top
Reset View Drop Down
Newbie
Newbie


Joined: 13 Jan 2020
Status: Offline
Points: 99
Post Options Post Options   Thanks (0) Thanks(0)   Quote Reset Quote  Post ReplyReply Direct Link To This Post Posted: 25 Apr 2020 at 7:30pm
Press F11 while booting and start the USB stick as "UEFI", then it works
Back to Top
dannykujo View Drop Down
Newbie
Newbie


Joined: 25 Apr 2020
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote dannykujo Quote  Post ReplyReply Direct Link To This Post Posted: 25 Apr 2020 at 10:44pm
I tried hitting f11 when turning on the pc. There is no option to to start the usb as UEFI because it does not appear there. All I see is "Please select boot device NVME:...." "Enter setup" "Boot Default"
Back to Top
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 3139
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 26 Apr 2020 at 1:35am
try a different usb stick ?
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.129 seconds.