ASRock.com Homepage
Forum Home Forum Home > Technical Support > HTPC&Gaming Barebone&Others
  New Posts New Posts RSS Feed - DeskMini A300 Failure Where do I go from here?
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

DeskMini A300 Failure Where do I go from here?

 Post Reply Post Reply
Author
Message
Sundancer268 View Drop Down
Newbie
Newbie


Joined: 02 Dec 2020
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Sundancer268 Quote  Post ReplyReply Direct Link To This Post Topic: DeskMini A300 Failure Where do I go from here?
    Posted: 02 Dec 2020 at 8:21am
My Build.

ASRock DeskMini A300W System
AMD Athlon 3000G CPU
Crucial Ballistix Sport LT 8 GB DDR4-2666 CL16 Memory     One Each
Kingston A400 480 GB 2.5" Solid State Drive          Two Each

Problem. When I plug in the Power Brick, the Blue Light on the Power Button lights up and that is where things stop. When I press the Power Switch, I get no CPU Fan running, No Video. The Monitor works on my Main Computer as the Second Screen so it is not the issue. Do I have a Dud and need to RMA it to ASRock or am I missing some trouble shooting steps? I have reset the BIOS with no change in symptoms, I have moved the memory to the other slot with no change. I have removed the CPU and find no bent pins and it drops into the socket with no resistance. This is my fourth computer build and the first time I have used ASRock and an AMD CPU, Where else do I go?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.180 seconds.