ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - "This MCU is empty error" - ASRock Polysync on B45
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

"This MCU is empty error" - ASRock Polysync on B45

 Post Reply Post Reply
Author
Message
Paradigm View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Dec 2020
Location: USA
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paradigm Quote  Post ReplyReply Direct Link To This Post Topic: "This MCU is empty error" - ASRock Polysync on B45
    Posted: 10 Dec 2020 at 12:12pm
Hi guys hope your doing well.

I just bought the ASRock B450 Steel Legend with a bunch of Addressable RGB Fans that are compatible with Polysync. Once I finished updating to the newest windows version I installed the newest version of Polysync. Whenever I try starting the program I get this error:

Error 0xFFF0
This MCU is empty!
Please restart this utility!



I've tried the main troubleshoots for this like restart my PC and flash my RGB but it still has not made a difference. I then found another post here that said too put your computer into deep sleep mode. I tried that and still nothing worked. I have no other RGB software on my PC. Right now I'm thinking that this is a hardware issue and I may need to RMA it. I did try running a older version but I got this error:

Error 0xFFFC
This utility is not for this platform!

Still have not found a fix for it. I am currently running the newest version of Windows 10 Pro 32 bit. Please Help!
Back to Top
ThreeDee View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24 Jul 2019
Location: Billings,MT
Status: Offline
Points: 2381
Post Options Post Options   Thanks (0) Thanks(0)   Quote ThreeDee Quote  Post ReplyReply Direct Link To This Post Posted: 10 Dec 2020 at 2:51pm
Why are your running Windows 10 32 bit?
|Ryzen 5 5900|ASRock X570 Taichi-BIOS 4.60|2x16GB HyperX Predator RGB 3200@3600 1:1 IF|ASRock RX 6700XT|2 x PCIe 4.0 M.2 Drives for OS & Games|850 WTT Seasonic 80+ Titanium PSU|Noctua NH-D15|
Back to Top
Paradigm View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Dec 2020
Location: USA
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paradigm Quote  Post ReplyReply Direct Link To This Post Posted: 10 Dec 2020 at 2:54pm
I'm sorry I meant Windows 10 Pro 64 bit.
Back to Top
ThreeDee View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24 Jul 2019
Location: Billings,MT
Status: Offline
Points: 2381
Post Options Post Options   Thanks (0) Thanks(0)   Quote ThreeDee Quote  Post ReplyReply Direct Link To This Post Posted: 10 Dec 2020 at 3:06pm
so you are running [Beta] ASRock Polychrome RGB ver:2.0.83? Have you tried right clicking on the install file and running as administrator? .. might help .. might not ..
|Ryzen 5 5900|ASRock X570 Taichi-BIOS 4.60|2x16GB HyperX Predator RGB 3200@3600 1:1 IF|ASRock RX 6700XT|2 x PCIe 4.0 M.2 Drives for OS & Games|850 WTT Seasonic 80+ Titanium PSU|Noctua NH-D15|
Back to Top
Paradigm View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Dec 2020
Location: USA
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paradigm Quote  Post ReplyReply Direct Link To This Post Posted: 10 Dec 2020 at 3:08pm
Yeah I did I still get the same error. I think it could be my bios as it is on version 3.2 not 3.7.
Back to Top
Paradigm View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Dec 2020
Location: USA
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Paradigm Quote  Post ReplyReply Direct Link To This Post Posted: 11 Dec 2020 at 1:08am
Update: I updated the Bios and got the same exact error "This MCU is empty" I will be RMA'ing it because it is most likely defective.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.156 seconds.