ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X399 Taichi not booting up, only LED light on
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X399 Taichi not booting up, only LED light on

 Post Reply Post Reply
Author
Message
Kevinchen00 View Drop Down
Newbie
Newbie
Avatar

Joined: 11 Jan 2021
Location: San Diego
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kevinchen00 Quote  Post ReplyReply Direct Link To This Post Topic: X399 Taichi not booting up, only LED light on
    Posted: 11 Jan 2021 at 3:31am
All

Desperately Needing some advices here. I am trying to put together a pc with the following configuration but was not able to boot up at all.

Asrock x399 taichi mb
Threadripper 2950x
128gb (32x4) Corsair vengeance RGB pro DDR4 3200 (PC 4-25600) C16 (I?m not planning to oc)
EVGA supernova 1300w G2 PSU (I got 1300w because I planned to add 2 gpu)
Gtx 1080 ti
Samsung 970 EVO 1tb
Barracuda had 2gb
Be quiet dark rock pro tr4 cooling fan
Lancool II case

When I first turned on the power on PSU after putting it all together, none of the cpu/case fans ran, neither did the psu fan, only the blue LED behind the asrock gear lit solid (no flashing). Nothing changed whether I pressed the power button on mb or on the front panel. And dr. debug is not lit at all so there is no debug info. To troubleshoot, I first verified that the PSU is functioning correctly by plugging the 24pin mb power, and 8 pin atx/cpu power into a PSU tester (note that I did plug in both 8 pin and 4 pin to mb when I tried to boot up. But the tester only takes one 8 pin). It appeared to produce the right voltage. Furthermore, the psu fan turned, which I did not observe when connecting to mb and powered on. Then I decided to take out the mb from the case and remove one component at a time, including removing ram, cpu, the situation remained the same. I have also tried to swap out the Corsair ram and put in with another two sticks of gskill ripjaws v 8gb, 3000. Then tested it along with just cpu, no luck. Tried to reseat the cpu, same thing. Also note that the psu fan did not run at all.

A picture is provided here shows what it looks like   https://imgur.com/a/oSoo4yE

I have to admit that the last time I put together a pc myself was ten years ago so I hope I didn?t miss anything obvious here. In this bare minimum testing, what should I observe in terms of psu fan, dr debug, etc.? Also, I did press the power switch on mb, nothing changed. Anything else I need to do? Btw, I also tried the cmos switch, and take out and put back the cmos battery. I saw some discussion about bios update, but not sure if it?s relevant at this point.

Any suggestions?








Kevin
Back to Top
muziqaz View Drop Down
Groupie
Groupie
Avatar

Joined: 04 Jan 2021
Location: London
Status: Offline
Points: 590
Post Options Post Options   Thanks (0) Thanks(0)   Quote muziqaz Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2021 at 8:40pm
Faulty motherboard?
I mean if RAM is faulty, you get dr debug or some LEDs light up and warn you, if GPU is dead, you also get everything light up and tell you GPU is dead. I'm yet to come across dead CPU, so have no idea how system behaves with dead CPU.
folding@home
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.102 seconds.