ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Asrock B450 Pro Updated Bios Nothing Loading
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Asrock B450 Pro Updated Bios Nothing Loading

 Post Reply Post Reply
Author
Message
sudeepharya View Drop Down
Newbie
Newbie


Joined: 22 May 2021
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote sudeepharya Quote  Post ReplyReply Direct Link To This Post Topic: Asrock B450 Pro Updated Bios Nothing Loading
    Posted: 22 May 2021 at 8:02am
Hi I just updated my ASROCK B450 Pro to the latest Bios v5.0 (from 4.4) it updated successfully using the instant flash tool. However after it rebooted nothing comes up on my monitor.

The monitor is connected to my motherboards VGA port.

I tried a CMOS reset with the battery and jumpers this did not work.

I pulled out any cards attached to MOBO but no luck.

All the fans and power turns on but there is no BIOS boot showing on the display just a black screen. Can anyone provide guidance please
Back to Top
ThreeDee View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24 Jul 2019
Location: Billings,MT
Status: Offline
Points: 2381
Post Options Post Options   Thanks (0) Thanks(0)   Quote ThreeDee Quote  Post ReplyReply Direct Link To This Post Posted: 22 May 2021 at 7:00pm
what CPU are you running?

is this the B450M Pro4 R2.0 that you are running? (only "Pro" board that I could see with a 4.40 BIOS revision)
|Ryzen 5 5900|ASRock X570 Taichi-BIOS 4.60|2x16GB HyperX Predator RGB 3200@3600 1:1 IF|ASRock RX 6700XT|2 x PCIe 4.0 M.2 Drives for OS & Games|850 WTT Seasonic 80+ Titanium PSU|Noctua NH-D15|
Back to Top
datonyb View Drop Down
Senior Member
Senior Member


Joined: 11 Apr 2017
Location: London U.K.
Status: Offline
Points: 3094
Post Options Post Options   Thanks (0) Thanks(0)   Quote datonyb Quote  Post ReplyReply Direct Link To This Post Posted: 22 May 2021 at 10:28pm
might be another case of asrocks removal of some previous bios versions

as threedee said we need the exact model of your b450

and exactly what cpu your using
im guessing its a g class apu if your using the mainboards video output
[url=https://valid.x86.fr/jpg250][/url]

3800X, powercolor reddevil vega64, gskill tridentz3866, taichix370, evga750watt gold
Back to Top
Sanderguy777 View Drop Down
Newbie
Newbie
Avatar

Joined: 18 Jul 2021
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote Sanderguy777 Quote  Post ReplyReply Direct Link To This Post Posted: 18 Jul 2021 at 4:14am
This is late, I know, but I am having a similar issue, but can see the bios on an older TV, while it doesn't work on my newer monitor. I would try hooking the PC up to your TV and see if it works.

Did the computer get into windows and just show a black screen during the part where you could open the Bios? Or does it just NOT work at all?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.078 seconds.