Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - x470 Taichi mobo won't power up after transplant
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

x470 Taichi mobo won't power up after transplant

 Post Reply Post Reply
lordfattimus View Drop Down

Joined: 08 Jan 2022
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote lordfattimus Quote  Post ReplyReply Direct Link To This Post Topic: x470 Taichi mobo won't power up after transplant
    Posted: 08 Jan 2022 at 12:23am
Hey all,

Tried to transplant an x470 Taichi mobo with AMD Ryzen 7 3800 into a different case today. Setup was working fine in prior case.

Got everything plugged in, hit power switch and nothing happens. The LEDs light up and blink passively. I have a USB light strip that gets power through a USB port.

I've tried every iteration of having everything unplugged including 8-pin ATX cable, taking out of case onto nonconductive surface, trying other PSU that is confirmed working on other setup, shorting the power button pins with screwdriver, with/without PCI devices CPU or HDD, etc etc everything that I can think of.

In the process I took out and reseated the CPU. I found that my family member who build it probably put it together too tight and with too much paste. He looooves the paste. When I removed the CPU I found about 5 pins that were bent into adjacent pins, I bent them back and it reseats properly. I'm not sure if that could have happened somehow during transfer today or if it's been like that a while.

One person on reddit suggested checking the I/O panel for a short as that happened to him. Everything looks ok to me on the I/O panel.

My only guess is that somehow during transfer I fried the mobo. I don't really understand how it could have happened; I always ground myself constantly when working on builds. There's no liquids around or anything else weird going on. Could those CPU pins have done it? Could some stray screw touching the back of the board at some point permanently fried it? I just find it hard to believe some small thing happened that I couldn't even notice while being extremely careful fried it instantly like this.

Can anyone think of anything to try that I haven't yet? I can't RMA something like this can I? I bought off amazon >1yr ago.

Thanks for any replies!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.031 seconds.