ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD and Intel Graphics Card
  New Posts New Posts RSS Feed - Monitor not getting a signal from graphics card
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Monitor not getting a signal from graphics card

 Post Reply Post Reply
Author
Message
Ribbey1 View Drop Down
Newbie
Newbie
Avatar

Joined: 14 Jun 2022
Location: USA
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ribbey1 Quote  Post ReplyReply Direct Link To This Post Topic: Monitor not getting a signal from graphics card
    Posted: 14 Jun 2022 at 9:09am
When I plug my monitors into my gpu they do not get any signal - I have been having over heating issues with my cpu so I got a new case and cpu cooler but after I rebuilt it my monitors didn?t work. If you have any ideas don?t hesitate to say so at this point no idea is a bad idea.
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 15168
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 14 Jun 2022 at 10:39pm
Double check all your power connections and that the card is properly seated.
You didn't list your system specs so if you have an intel system make sure your
CPU cooler is not tightened down too hard, this can cause uneven pressure on the
CPU and cause an edge to lift off the pins, or worse, bend the CPU substrate and
lift the corners. If it's an AMD system double check that you haven't missed a
power cable like the 8pin CPU power.

If the system was working in the old case with the old cooler odds are, unless
you physically damaged something (unlikely), it's something simple you overlooked.
Go over everything carefully step by step and if all else fails, pull it all
apart and reassemble starting with just the essentials.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.094 seconds.