ASRock.com Homepage
Forum Home Forum Home > Media&User's Review > AMD Motherboards
  New Posts New Posts RSS Feed - Steel Legend B550 NVMe not recognized
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Steel Legend B550 NVMe not recognized

 Post Reply Post Reply
Author
Message
bala61091 View Drop Down
Newbie
Newbie
Avatar

Joined: 08 Jul 2022
Location: India
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote bala61091 Quote  Post ReplyReply Direct Link To This Post Topic: Steel Legend B550 NVMe not recognized
    Posted: 08 Jul 2022 at 3:16pm
Hi all!
I bought steel legend B550 and coupled it with Ryzen 5 5600G and XPG D60G 8GBx2. No graphic card installed. I have installed XPG S5 m.2 256GB in hyper m.2 port.
I had to flash the BIOS to support my 5600G using a 3600. Updated successfully but I am unable to find NVMe under boot devices. Installed 2TB HDD and booted up Windows 10 and no NVMe in windows either.

Pls help me out here.

Additional info: Flashed BIOS to 2.1 version and NVMe was showing for the first time and after restart the problem continues. Currently using 2.2 version BIOS.
BK
Back to Top
threadzipper1957 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 05 Mar 2022
Status: Offline
Points: 6055
Post Options Post Options   Thanks (0) Thanks(0)   Quote threadzipper1957 Quote  Post ReplyReply Direct Link To This Post Posted: 22 Jul 2022 at 9:00pm
Try the following.
Connect only the M.2.
In BIOS, go to boot, and check if CSM is disabled
use f11 to get into the bootmenu, then selct the Windows installation USB stick.
It should start with th elanguage and keyboard layout settings, at this point press Shift-f10 to open a command prompt
Start diskpart by typing diskpart, there you need 3 commands
List disk (shows de device ID's, usually an M.2 is ID0)
Select disk {ID number} to select the disk you want to administer
When you use the arrow Up key you can scroll through the commands
when you run list disk again, you will see a star in front of the selected ID
if that is correct, type clean to wipe not only the partition, but also the partitioning.
Another list disk, will show both Size and free space is identical meaning the drive is wiped.
Once that is done, type exit to exit diskpart, and exit the command prompt, by typing in Exit.
Now you're back in the Windows setup menu, and can continue the setup.
When Windows has been activated on this PC, you can select I don't have a license key, select the version that was activated before so Pro when you activated it with Pro, home, when it was actiavted with home, and use a custom setup.
Let windows do the partitioning and formatting
after Windows is installed first install the latest AMD chipset driver
https://www.amd.com/en/support/chipsets/amd-socket-am4/b550
If this still doesn't work, check if there is a firmware update for the M.2
Kind Regards
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.109 seconds.