ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - X299e-ITX Nothing happening on power up.
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

X299e-ITX Nothing happening on power up.

 Post Reply Post Reply
Author
Message
Intuition_1977 View Drop Down
Newbie
Newbie
Avatar

Joined: 04 Aug 2022
Location: Los Angeles
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote Intuition_1977 Quote  Post ReplyReply Direct Link To This Post Topic: X299e-ITX Nothing happening on power up.
    Posted: 04 Aug 2022 at 11:07am
Hello,

I purchased this motherboard quite a few years ago but it has been in the box brand new until I finally acquired all the parts I needed to build the computer with it.

CPU: i9 7980XE 18 core
RAM: Vengeance Corsair DDR4 3200 4x16gb for 64gb
GPU: Nvidia 3070

PSU: Corsair RM850
Case: NZXT Manta

I have probably built about 20 computers in my life from parts so I have completed builds many times before.

This is the first time a powerup didn't post at least a Bios.

I booted down and reseated everything I could think of.

RAM one per slot try to boot each time.
Checked the M.2 expansion card... etc.

I am not sure what to do here.

There is no light on the motherboard letting me know the power is on except the fact that the ethernet port, when the cat6 cable is plugged in, does flash yellow off and on.

Since I didn't see anything sent to the screen or hear any beeps I swapped video cards with my working main rig to make sure it wasn't the graphics card.

I also tried the hold the CMOS reset button down as I found another post saying the same thing happened to another customer in 2020.

Sure enough the graphics cards worked in my older computer just fine and sent a signal to the screen.

Is there a way to RMA this motherboard?

It is the first one I have ever experienced not having at least a logo or Bios post to the screen.

Thanks for any info or suggestions you have.
Back to Top
Intuition_1977 View Drop Down
Newbie
Newbie
Avatar

Joined: 04 Aug 2022
Location: Los Angeles
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote Intuition_1977 Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2022 at 11:24am
Back to Top
Intuition_1977 View Drop Down
Newbie
Newbie
Avatar

Joined: 04 Aug 2022
Location: Los Angeles
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote Intuition_1977 Quote  Post ReplyReply Direct Link To This Post Posted: 04 Aug 2022 at 3:20pm
Also, if there is no RMA option cause of how old the board is... I am still interested in it being repaired if you have that as a service.

Back to Top
Gamer313 View Drop Down
Newbie
Newbie


Joined: 20 May 2021
Status: Offline
Points: 160
Post Options Post Options   Thanks (0) Thanks(0)   Quote Gamer313 Quote  Post ReplyReply Direct Link To This Post Posted: 13 hours 49 minutes ago at 8:42am
You should contact support and provide info of all components in use, including model numbers, as well as a detailed description of the problem, including any changes before problem began.

Support page is at https://www.asrock.com/support/index.asp?cat=RMA
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.078 seconds.