ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - M.2 Gen4 x4 not working on Z490 'Hyper' M.2 Slot
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

M.2 Gen4 x4 not working on Z490 'Hyper' M.2 Slot

 Post Reply Post Reply
Author
Message
arkhen View Drop Down
Newbie
Newbie


Joined: 25 Aug 2022
Location: Brazil
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote arkhen Quote  Post ReplyReply Direct Link To This Post Topic: M.2 Gen4 x4 not working on Z490 'Hyper' M.2 Slot
    Posted: 25 Aug 2022 at 9:31pm
Hey guys

I just got an M.2 PCIe Gen4 x4 NVMe (XPG Gammix S70 Blade) and I'm trying to install it in the 'Hyper' M2 slot on my 'Z490 Steel Legends' Motherboard, but it simply does not detect it.

The specifications of the motherboard says:
ASRock Hyper M.2 (PCIe Gen4 x4)
ASRock Ultra M.2 (PCIe Gen3 x4 & SATA3)

So I guess the best slot to have this new M.2 Gen4 at full speed is indeed the Hyper slot.

When I install it in the 'Ultra' Gen3 slot the M.2 works, although of course at a lower speed (3500 mb/s) compared to it's full 7400mb/s potential.

I currently have an M.2 SSD Gen3 ADATA (XPG SPECTRIX S40G) working well on the M2_2 (Ultra slot) and I remember trying to install it on the M2_1 (Hyper) slot, when I got it years ago, but it also did not work. It's like the slot is disabled.

Does anyone knows how to make it work?
Is this a problem of compatibility or is there a way to activate this 'Hyper' slot on the BIOS settings?

(My Processor is an INTEL CORE I9-10900, 20MB, 2.8GHZ, LGA 1200)
Back to Top
threadzipper1957 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 05 Mar 2022
Status: Offline
Points: 6040
Post Options Post Options   Thanks (0) Thanks(0)   Quote threadzipper1957 Quote  Post ReplyReply Direct Link To This Post Posted: 20 Sep 2022 at 7:08pm
It is correct that the M2_1 slot doesn't work.
The reason is that a 10th Gen CPU, does not have enough PCIE lanes to enable this slot.
this only works with the 11th gen CPU, who has 4 additional PCIE lanes
It is also stated in the sepcs on the ASRock website
https://www.asrock.com/mb/Intel/Z490%20Steel%20Legend/index.asp#Specification
Kind Regards
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.113 seconds.