ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - AMD B450 Pro4 not booting with more than 4 drives
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

AMD B450 Pro4 not booting with more than 4 drives

 Post Reply Post Reply
Author
Message
JoshuaDunnink View Drop Down
Newbie
Newbie
Avatar

Joined: 29 Nov 2022
Location: Netherlands
Status: Offline
Points: 65
Post Options Post Options   Thanks (0) Thanks(0)   Quote JoshuaDunnink Quote  Post ReplyReply Direct Link To This Post Topic: AMD B450 Pro4 not booting with more than 4 drives
    Posted: 29 Nov 2022 at 7:04pm
Hey all,

Im trying to add disks to my pc to store and access my photos whenever needed. However I find that when I add the 5th drive, the PC no longer boots. It keeps hanging in the "ASROCK loading screen". Upon restart it sometimes, so not always, tries to innitiate a drive repair but hangs afterwards aswell.

Working drive setup with Boot set on NVMe:
(NVMe) M2_1,
SATA3_1
SATA3_2
SATA3_A1

Any drive added to either one of the available connectors will stop boot:
SATA3_A2
SATA3_3
SATA3_4


(mSATA)M2_2 has not been occupied to allow SATA3_3 and SATA3_4 to work.



Does anyone know what im doing wrong? or is there a limitation on the board or cpu (Ryzen 5 1600) combination for example?
Back to Top
JoshuaDunnink View Drop Down
Newbie
Newbie
Avatar

Joined: 29 Nov 2022
Location: Netherlands
Status: Offline
Points: 65
Post Options Post Options   Thanks (0) Thanks(0)   Quote JoshuaDunnink Quote  Post ReplyReply Direct Link To This Post Posted: 29 Nov 2022 at 7:05pm
for reference,
Manual to the ASROCK B450 Pro4

https://download.asrock.com/Manual/B450%20Pro4.pdf
Back to Top
JoshuaDunnink View Drop Down
Newbie
Newbie
Avatar

Joined: 29 Nov 2022
Location: Netherlands
Status: Offline
Points: 65
Post Options Post Options   Thanks (0) Thanks(0)   Quote JoshuaDunnink Quote  Post ReplyReply Direct Link To This Post Posted: 29 Nov 2022 at 7:20pm
Some other additional info.
In the BIOS I see that all drives are accounted for.

There is an explicit setting for booting on NVMe only,
so even in the case there be something bootable on any of the drives, it should disregard that.

eventhough I expect this not to be the case as it also hangs on an empty disk when added, could the presence of a second bootable device still cause a race condition?
Back to Top
JoshuaDunnink View Drop Down
Newbie
Newbie
Avatar

Joined: 29 Nov 2022
Location: Netherlands
Status: Offline
Points: 65
Post Options Post Options   Thanks (0) Thanks(0)   Quote JoshuaDunnink Quote  Post ReplyReply Direct Link To This Post Posted: 02 Dec 2022 at 6:01am
I just found out that this board has BIOS P4.50 installed while I am running with a Ryzen 5 1600 (Summit Ridge).

*ASRock do NOT recommend updating this BIOS if Pinnacle, Raven or Summit Ridge CPU is being used on your system.

According to BIOS specs, this version should not run with this type CPU.
Can these issues arise from that and should I downgrade my BIOS to P3.50 if even possible,

(or upgrade the CPU)
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.141 seconds.