ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - A320M-ITX BIOS Update Creates PCIe Problems
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

A320M-ITX BIOS Update Creates PCIe Problems

 Post Reply Post Reply
Author
Message
gentlemutton View Drop Down
Newbie
Newbie
Avatar

Joined: 07 Dec 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote gentlemutton Quote  Post ReplyReply Direct Link To This Post Topic: A320M-ITX BIOS Update Creates PCIe Problems
    Posted: 07 Dec 2022 at 11:04pm
I updated the BIOS to try and fix some occasional instability (freezes), and my PCIe card isn't working anymore. I get continuous I/O Errors with the drives on the card.

The drives are healthy and the card had been working for years before the update. The only thing that changed is the BIOS version.

Motherboard: ASRock A320M-ITX
BIOS: 7.40
CPU: AMD Ryzen 2400G
PCIe: PCIE x1 to 4 port SATA Card // Part No. P-PCE4SAT-A01-003
OS: Debian 'Bullseye' Linux (5.10.140-1)

Errors:




Any tips to get the card up and running again?
Back to Top
SerchTech View Drop Down
Groupie
Groupie
Avatar

Joined: 16 Oct 2022
Location: Spain
Status: Offline
Points: 475
Post Options Post Options   Thanks (0) Thanks(0)   Quote SerchTech Quote  Post ReplyReply Direct Link To This Post Posted: 08 Dec 2022 at 1:02am
Hi

Perhaps the latest BIOS versions disable CSM by default, have you checked?

You can confirm it in BIOS checking Boot tab.


Good luck
X399 Taichi | TR 2950X | 64GB HyperX 3200Mhz | 2 x RTX 3060
Back to Top
gentlemutton View Drop Down
Newbie
Newbie
Avatar

Joined: 07 Dec 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote gentlemutton Quote  Post ReplyReply Direct Link To This Post Posted: 08 Dec 2022 at 4:33am
CSM is still enabled.

I toggled it both on & off to no avail.
Back to Top
gentlemutton View Drop Down
Newbie
Newbie
Avatar

Joined: 07 Dec 2022
Status: Offline
Points: 50
Post Options Post Options   Thanks (0) Thanks(0)   Quote gentlemutton Quote  Post ReplyReply Direct Link To This Post Posted: 13 Dec 2022 at 4:48am
[SOLVED]: I bought a Gigabyte motherboard and the problem is gone.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.141 seconds.