ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Z790 Steel Legend WiFi  XMP help
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Z790 Steel Legend WiFi XMP help

 Post Reply Post Reply
Author
Message
Birdo View Drop Down
Newbie
Newbie


Joined: 19 Jan 2023
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote Birdo Quote  Post ReplyReply Direct Link To This Post Topic: Z790 Steel Legend WiFi XMP help
    Posted: 19 Jan 2023 at 8:50am
Hey Team,

I am trying to run a Corsair dominator 32gig (2x16) 6200mhz Ram kit,   I turn on XMP 3.0 but I don't get more than 4400 MHz,

Am I doing something wrong? have I missed something?

I have the Ram in A1 and B1 for dual channels, I have also updated the latest Bios.

Any help would be muchly appreciated.

Back to Top
threadzipper1957 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 05 Mar 2022
Status: Offline
Points: 9335
Post Options Post Options   Thanks (1) Thanks(1)   Quote threadzipper1957 Quote  Post ReplyReply Direct Link To This Post Posted: 16 Mar 2023 at 11:49pm
memory should be in A2 B2
But Corsair is not a manufacturer, they are assemblers, who constantly chenge the chips they solder onto the PCB, I always had the best results with patriot Viper
Maybe also use the latest BIOS
https://www.asrock.com/mb/Intel/Z790%20Steel%20Legend%20WiFi/index.asp#BIOS
The memory controller is NOT on the board, it is integrated in the CPU, and 12th Gen optimal speed is 4800MHz, 13th Gen 5600MHz
https://www.intel.com/content/www/us/en/products/compare.html?productIds=134594,230500
Try using XMP, and select the DRAM speed that goes fopr Your CPU, and before doing that, reset the BIOS to default values with f9 and save with f10
Kind Regards
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.176 seconds.