ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Ryzen 9 5900 OEM not working on Taichi B550
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Ryzen 9 5900 OEM not working on Taichi B550

 Post Reply Post Reply
Author
Message
alexbo View Drop Down
Newbie
Newbie


Joined: 23 Aug 2023
Location: Spain
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote alexbo Quote  Post ReplyReply Direct Link To This Post Topic: Ryzen 9 5900 OEM not working on Taichi B550
    Posted: 23 Aug 2023 at 11:21pm
Hi,
I bought a Ryzen 9 5900 (without the X, as its the OEM version), but when updating my current ryzen 5 3600, the new CPU gets only detected by BIOS on version 2.0 but will not continue to load windows.
I cant even get any windows or linux bootable usb to work either. It stays in constant "loading mode" nothing happens.
Yes, I have tried rufus with MBR and GPT as well as all possible combinations of CSM enabled, even secure boot disabled, cleared CMOS... Everything!

If I update to newer versions, it simply doesnt boot at all.
In the LCD display I get codes: 27 or 28. And nothing else happens.

Does somebody know if there is a specific BIOS I should use for this Ryzen 9 cpu?

I would really appreciate if someone could help me here.

Thanks a lot
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 13.172 seconds.