ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Create Soundblaster Issues
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Create Soundblaster Issues

 Post Reply Post Reply
Author
Message Reverse Sort Order
90Ninety View Drop Down
Newbie
Newbie


Joined: 01 Oct 2023
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote 90Ninety Quote  Post ReplyReply Direct Link To This Post Topic: Create Soundblaster Issues
    Posted: 01 Oct 2023 at 4:52am
OK I figured out the problem

The 'Realtek high definition audio Driver' when installed shows as Realtek Audio device ( the HD part is missing ) . This was the clue
This driver turned out to be incompatible or just maybe only works with the Windows store version of Soundblaster ( connect )
I installed a Realtek HD driver from a different Asrock motherboard here https://www.asrock.com/MB/Intel/Fatal1ty%20Z270%20Gaming%20K6/index.asp#osW1064

This driver worked fine with the Soundblaster cinema 3 , included on the Asrock AB350 Fat1ty Gaming ITX
Back to Top
90Ninety View Drop Down
Newbie
Newbie


Joined: 01 Oct 2023
Status: Offline
Points: 35
Post Options Post Options   Thanks (0) Thanks(0)   Quote 90Ninety Quote  Post ReplyReply Direct Link To This Post Posted: 01 Oct 2023 at 3:45am

I have always had issues with creative soundblaster , seems it needs a specific driver to work with a specific version of soundblaster

Currently having this issue with Windows 11 on a AB350 Fatility ITX (latest bios)


I have tried installing both the Win 11 and Win 10 drivers from the Asrock Board website , along with the Soundblaster Cinema 3 software. However the software fails to find the supported device . I see this is a common issue , actually had the same problem with Gigabyte boards

Interestingly the driver folder has 'SBConnect5' in its title , and the software is named SB Cinema 3 .. So something clearly not right

SBconnect is also no longer available on Windows store ..

So at a loss on how to get this working
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.129 seconds.