ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - B550M PRO4 not detecting new AX210 Wifi Adapter
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

B550M PRO4 not detecting new AX210 Wifi Adapter

 Post Reply Post Reply
Author
Message
zr0gravity7 View Drop Down
Newbie
Newbie


Joined: 12 Oct 2023
Status: Offline
Points: 65
Post Options Post Options   Thanks (0) Thanks(0)   Quote zr0gravity7 Quote  Post ReplyReply Direct Link To This Post Topic: B550M PRO4 not detecting new AX210 Wifi Adapter
    Posted: 12 Oct 2023 at 8:57am
I had been using my build with an Ethernet connection, but recently need to switch to wireless.

I purchased a new Intel AX210 network adapter, and slotted it into the board M2 Wifi PCIe slot. Connected the antennae, booted up, installed both Wifi and Bluetooth drivers from Intel website.

Now Bluetooth is working in Windows settings, but not Wifi.

Further, the device is not even recognized in Device Manager.

Instead, under Network adapters it shows:
- Bluetooth device (Personal Area Network)
- Realtek PCIe GbE Family Controller

Additionally, under System devices, there is one device "PCI Express Downstream Switch Port which has a warning icon, and status:
"This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

The specified request is not a valid operation for the target device."

I don't know if this was present before attempting the installation, but I figure it might be related.

Do I need to update any additional drivers? Is there a change to be made in the BIOS?

How can I go about troubleshooting this?
Back to Top
zr0gravity7 View Drop Down
Newbie
Newbie


Joined: 12 Oct 2023
Status: Offline
Points: 65
Post Options Post Options   Thanks (0) Thanks(0)   Quote zr0gravity7 Quote  Post ReplyReply Direct Link To This Post Posted: 12 Oct 2023 at 9:08am
After showing hidden devices in Device Manager, I see a new device under Network adapters:
- Microsoft Kernel Debug Network Adapter

I also found this forum which seems to describe a similar problem (I was already on Windows 11): https://h30434.www3.hp.com/t5/Desktop-Wireless-and-Networking/No-WiFi-after-windows-update/td-p/7446936

Sadly the fix did not work for me.
Back to Top
eccential View Drop Down
Senior Member
Senior Member
Avatar

Joined: 10 Oct 2022
Location: Nevada
Status: Offline
Points: 4480
Post Options Post Options   Thanks (0) Thanks(0)   Quote eccential Quote  Post ReplyReply Direct Link To This Post Posted: 12 Oct 2023 at 7:25pm
I'm not saying this is the problem, but are you sure you got an AX210 and not an AX211? The xx1 models lack certain hardware and instead depend on built-in logic inside Intel SoC, so xx1 models won't work in AMD systems.
Back to Top
zr0gravity7 View Drop Down
Newbie
Newbie


Joined: 12 Oct 2023
Status: Offline
Points: 65
Post Options Post Options   Thanks (0) Thanks(0)   Quote zr0gravity7 Quote  Post ReplyReply Direct Link To This Post Posted: 13 Oct 2023 at 8:51am
Yes I am sure. The vendor is somewhat reputable, and I checked the sticker on the card.
Back to Top
Lele View Drop Down
Newbie
Newbie


Joined: 24 Dec 2023
Location: Germany
Status: Offline
Points: 30
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lele Quote  Post ReplyReply Direct Link To This Post Posted: 24 Dec 2023 at 10:03pm
Hello, I have the same pronlem with the b550m pro4 and the intel ax200. For me only bluetooth is being detected and not wifi. The device manager also only show
- Bluetooth device (Personal Area Network)
- Realtek PCIe GbE Family Controller
- Microsoft Kernel Debug Network Adapter
and in the bios the adapter also is not showing up. Does somebody know why?
or do you @zrOgravity7 have found a solution how to fix the issue?
Back to Top
Lele View Drop Down
Newbie
Newbie


Joined: 24 Dec 2023
Location: Germany
Status: Offline
Points: 30
Post Options Post Options   Thanks (0) Thanks(0)   Quote Lele Quote  Post ReplyReply Direct Link To This Post Posted: 24 Dec 2023 at 10:05pm
I also tried it with the ax210 before but had the same issue.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.133 seconds.