ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - PC randomly boots to iGPU instead of discrete GPU
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

PC randomly boots to iGPU instead of discrete GPU

 Post Reply Post Reply
Author
Message
bookthief1221 View Drop Down
Newbie
Newbie
Avatar

Joined: 20 Feb 2024
Status: Offline
Points: 20
Post Options Post Options   Thanks (0) Thanks(0)   Quote bookthief1221 Quote  Post ReplyReply Direct Link To This Post Topic: PC randomly boots to iGPU instead of discrete GPU
    Posted: 20 Feb 2024 at 4:32pm
I have a B650E PG Riptide WiFi with a 7800X3D and 4080 super FE. The monitor is connected to the discrete GPU port directly. I have issues with the system booting to the iGPU instead of the discrete card (or randomly, the opposite). Sometimes, the system goes through a boot cycle a few times before settling. The red debug LED's on the motherboard turn off and on in a cycle and eventually go out. When booting, I see the Asrock splash screen briefly before it switches to the iGPU output.

I eventually went into the BIOS settings while connected to the motherboard video output, and I tried to changing the GXF configuration settings to specify "iGPU disabled" and "auto detect discrete display enabled." However, this doesn't seem to have worked (at least consistently enough). Note that I unplug the HDMI cable from the motherboard when testing, but I need it to actually get into the BIOS to change things.

Other things I've tried: downloaded latest drivers (at least everything recommended by the Asrock auto installer) and flashed the BIOS to both older and newest beta versions. Didn't work?”same problem. Still waiting on Asrock support for any kind of response (it's been a week, and I don't know what to do).

I've tried searching online for similar issues, but I couldn't find anything that worked.

Kind of disappointed by this board. This issue makes it impossible to actually use the system consistently. And Asrock support is basically MIA. Would appreciate any help here?”thanks!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.141 seconds.