ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - No BIOS with FX9590 CPU and 990X MB
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

No BIOS with FX9590 CPU and 990X MB

 Post Reply Post Reply
Author
Message Reverse Sort Order
wardog View Drop Down
Moderator Group
Moderator Group


Joined: 15 Jul 2015
Status: Offline
Points: 6447
Post Options Post Options   Thanks (0) Thanks(0)   Quote wardog Quote  Post ReplyReply Direct Link To This Post Topic: No BIOS with FX9590 CPU and 990X MB
    Posted: 28 Jul 2016 at 11:27am
Originally posted by lordtataraus lordtataraus wrote:

I seems to be what I forgot to do. It works fine now, thanks!!!


For myself and parsec to keep score LOL, what was it you forgot to do?
Back to Top
lordtataraus View Drop Down
Newbie
Newbie


Joined: 27 Jul 2016
Location: Seattle
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote lordtataraus Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jul 2016 at 9:18am
I seems to be what I forgot to do. It works fine now, thanks!!!
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (1) Thanks(1)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2016 at 11:27pm
Did you clear the BIOS after installing the FX 9590?

A 9590 will work with any BIOS version used by this board.
Back to Top
wardog View Drop Down
Moderator Group
Moderator Group


Joined: 15 Jul 2015
Status: Offline
Points: 6447
Post Options Post Options   Thanks (0) Thanks(0)   Quote wardog Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2016 at 4:19pm
8-pin CPU power not connected or CPU fan(pump?) connected to something other than a CPUFAN header?
Back to Top
lordtataraus View Drop Down
Newbie
Newbie


Joined: 27 Jul 2016
Location: Seattle
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote lordtataraus Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jul 2016 at 1:26pm
I recently purchased a FX 9590 CPU to replace my old Phenom II (motherboard is the FX 990 Extreme 9). However, after swapping in the new CPU and turning on the computer, the leds and fans switch on but nothing else happens. I checked to make sure everything is plugged in, but still nothing happens. I swapped back in my Phenom II and updated the BIOS, then swapped back (changing nothing but the cpu) and still nothing but a black screen with the 9590.

Do I just have a busted 9590 or is there something I might be missing?
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.125 seconds.