ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - Z97 Extreme4 issue with Turbo Boost on 2.50
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Z97 Extreme4 issue with Turbo Boost on 2.50

 Post Reply Post Reply
Author
Message
zifn4b View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Nov 2016
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote zifn4b Quote  Post ReplyReply Direct Link To This Post Topic: Z97 Extreme4 issue with Turbo Boost on 2.50
    Posted: 10 Nov 2016 at 4:48am
Hi,

I have an ASRock Z97 Extreme4 motherboard.  I had an issue earlier where the ASRock LiveUpdate app told me there was a new BIOS available 2.30->2.50.  I had it do the update and it made my system unbootable.  When I went into the BIOS, it was no longer in English.  Clearly something went wrong so I went to the web site and downloaded the 2.50 BIOS manually put it on a flash drive and then did instant update via the BIOS.  After that, my machine would boot but I noticed a problem.

When I disable Intel Turbo Boost, Speed step and all the C stuff, it still auto-overclocks instead of staying at a fixed frequency like the 2.30 BIOS did.  For reference I have an Intel i4790k and Windows 10 64-bit.  I also tried resetting to UEFI defaults and set everything back up but same thing.

The workaround to this issue is to go into Windows power management and advanced settings and set the Processor Power Management minimum and maximum processor state to 99% and then it is fixed at 3.96ghz but I didn't have to do this before.  I don't want to run automatically overclocked because the processor runs hot and I'm on the stock cooler.  I'm considering upgrading the cooler though.

Anyone know what the issue is?
Back to Top
wardog View Drop Down
Moderator Group
Moderator Group


Joined: 15 Jul 2015
Status: Offline
Points: 6447
Post Options Post Options   Thanks (0) Thanks(0)   Quote wardog Quote  Post ReplyReply Direct Link To This Post Posted: 10 Nov 2016 at 9:05am
Have you tried clearing the BIOS by removing the button cell battery and jumpering it if it has a CLRCMOS jumper and let it sit that way for between 10 and 30 minutes?

I'd try that first.

Then, from personal experiences do not use Internet Flash. Always, ALWAYS, use Instant Flash.
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (1) Thanks(1)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 10 Nov 2016 at 9:37am
Originally posted by zifn4b zifn4b wrote:

Hi,

I have an ASRock Z97 Extreme4 motherboard.  I had an issue earlier where the ASRock LiveUpdate app told me there was a new BIOS available 2.30->2.50.  I had it do the update and it made my system unbootable.  When I went into the BIOS, it was no longer in English.  Clearly something went wrong so I went to the web site and downloaded the 2.50 BIOS manually put it on a flash drive and then did instant update via the BIOS.  After that, my machine would boot but I noticed a problem.

When I disable Intel Turbo Boost, Speed step and all the C stuff, it still auto-overclocks instead of staying at a fixed frequency like the 2.30 BIOS did.  For reference I have an Intel i4790k and Windows 10 64-bit.  I also tried resetting to UEFI defaults and set everything back up but same thing.

The workaround to this issue is to go into Windows power management and advanced settings and set the Processor Power Management minimum and maximum processor state to 99% and then it is fixed at 3.96ghz but I didn't have to do this before.  I don't want to run automatically overclocked because the processor runs hot and I'm on the stock cooler.  I'm considering upgrading the cooler though.

Anyone know what the issue is?


Three possibilities about the language setting in the UEFI.

First, some UEFI's have a language selection option, so that might have been set to the wrong language. Usually in the Main UEFI screen.

Second, in the UEFI, Tools screen, in Network Configuration, the UEFI Download Server option was not set correctly. You might find it set to Auto, which normally works fine for me, I'm in the USA too.

Third, the App Shop program or LiveUpdate was somehow confused, or the USA server was down, and the UEFI file you received came from a different server that gave you a non-English UEFI version.

About your "auto over clock", it sounds like the CPU OC Fixed Mode option in OC Tweaker is set to Enabled. That can be the default value, or was changed to the default value in the UEFI version you have now.

Whether or not that is an "issue", depends upon your perspective. If it is the CPU OC Fixed Mode option, a UEFI setting is really not an issue.

BTW, if you want to keep the CPU from running at a higher speed to reduce heat with a Haswell CPU like yours, just set Turbo to Disabled. But you will want SpeedStep and C States enabled, unless the Windows Power Management option for the CPU work well enough for you to reduce the CPU speed and VCore when the CPU is idle. Your CPU may be at a lower speed with your method, but check the VCore when the CPU is at 800MHz. If it is not also reduced substantially, you are not getting the lowest temperatures you could have.

There are other ways to set the maximum processor speed to a lower value than the default values in OC Tweaker.
Back to Top
zifn4b View Drop Down
Newbie
Newbie
Avatar

Joined: 10 Nov 2016
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote zifn4b Quote  Post ReplyReply Direct Link To This Post Posted: 10 Nov 2016 at 8:50pm
Originally posted by parsec parsec wrote:


About your "auto over clock", it sounds like the CPU OC Fixed Mode option in OC Tweaker is set to Enabled. That can be the default value, or was changed to the default value in the UEFI version you have now.

Whether or not that is an "issue", depends upon your perspective. If it is the CPU OC Fixed Mode option, a UEFI setting is really not an issue.

BTW, if you want to keep the CPU from running at a higher speed to reduce heat with a Haswell CPU like yours, just set Turbo to Disabled. But you will want SpeedStep and C States enabled, unless the Windows Power Management option for the CPU work well enough for you to reduce the CPU speed and VCore when the CPU is idle. Your CPU may be at a lower speed with your method, but check the VCore when the CPU is at 800MHz. If it is not also reduced substantially, you are not getting the lowest temperatures you could have.

There are other ways to set the maximum processor speed to a lower value than the default values in OC Tweaker.


Thanks for the info!  I tried what you suggested but it's still running it at a higher clock speed with Turbo disabled.  CPU OC Fixed mode was set to auto (default value).  Setting this to disabled in tandem with Turbo being disabled still results in the CPU being run at 4.21ghz and I want it to run at its rated speed of 4ghz.  Should I just go back to the 2.30 UEFI?  It was behaving in what I believe to be appropriate when Turbo Boost was disabled.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.340 seconds.