ASRock.com Homepage
Forum Home Forum Home > Media&User's Review > AMD Motherboards
  New Posts New Posts RSS Feed - I cannot disable CSM, it enables automatically
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

I cannot disable CSM, it enables automatically

 Post Reply Post Reply
Author
Message
smarcelli View Drop Down
Newbie
Newbie


Joined: 10 Feb 2017
Location: Italy
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote smarcelli Quote  Post ReplyReply Direct Link To This Post Topic: I cannot disable CSM, it enables automatically
    Posted: 10 Feb 2017 at 3:45pm
Hi everyone.
I'm trying to install Windows 8 PRO (regular version from DVD) on my new ASRock FM2A68M-HD+.
Mission impossible because after saving and exit the boot it enables automatically. How can solve this annoying issue?
The combo motherboard and CPU is "ASRock FM2A68M-HD+". The disk on which I want to install win 8 is a Samsung SSD used that worked very well. Thank you for your help.
Regards,

smarcelli
Back to Top
Xaltar View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 16 May 2015
Location: Europe
Status: Offline
Points: 10368
Post Options Post Options   Thanks (0) Thanks(0)   Quote Xaltar Quote  Post ReplyReply Direct Link To This Post Posted: 10 Feb 2017 at 4:42pm
I am not sure what the problem is based on your post.

Boot options not saving in the UEFI? 
Failing to boot from the SSD?

I am sorry but I can only help if I understand the problem. Please also post your full system specs so we know what you are working with, include brand a models.
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 11 Feb 2017 at 12:50am
Originally posted by smarcelli smarcelli wrote:

Hi everyone.
I'm trying to install Windows 8 PRO (regular version from DVD) on my new ASRock FM2A68M-HD+.
Mission impossible because after saving and exit the boot it enables automatically. How can solve this annoying issue?
The combo motherboard and CPU is "ASRock FM2A68M-HD+". The disk on which I want to install win 8 is a Samsung SSD used that worked very well. Thank you for your help.


You're saying the CSM option, when set to Disabled, and you Save and Exit the UEFI, resets to Enabled by itself, correct?

Also the PC starts fine into the UEFI/BIOS when you do this, but later you find CSM is set back to Enabled, right?

If you have Windows installed with CSM Enabled, and then try to set it to Disabled, that will never work. You must install Windows with CSM disabled during the installation.

Like Xaltar said, I don't know if I understand exactly what your situation is.

What UEFI/BIOS version do you have in your board?

So we know, why do you want to disable CSM? Please explain why you want to do that? Just asking why. I know of several reasons, just wondering why you want to do it.

Some information about the CSM option:

CSM does not need to be disabled to install Win 8, or any version of Windows.

When you disable CSM, the video source in the PC must be compatible with a UEFI protocol called GOP. If the video source is not GOP compatible, you won't get anything on the monitor. What are you using for the video source in that PC? The built in video, or a video card?

As a safety feature, the UEFI/BIOS will reset CSM to Enabled if it detects a compatibility problem with the PC's hardware not being all UEFI compatible. I assume that is what is happening to you.

You can try the following to use some of the UEFI features without setting CSM to Disabled. Click the CSM option to open its sub-options. Find the Launch Storage OpROM Policy option, and set it to UEFI only.

Part of the problem may be using a disk/optical drive to install Windows 8 in UEFI booting mode (CSM disabled). If the boot order, when you try to install Win 8, the entry for the optical drive must look like this: "UEFI" <optical drive name>, or you cannot install in UEFI mode. Also, Windows 8 MUST be 64 bit, or you cannot disable CSM.

What is the SATA mode set to for the Samsung SSD? It must be AHCI mode.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.062 seconds.