ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - 970 extreme 3 ultra fast boot
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

970 extreme 3 ultra fast boot

 Post Reply Post Reply Page  12>
Author
Message
panabesk View Drop Down
Newbie
Newbie


Joined: 13 Aug 2015
Location: Greexe
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote panabesk Quote  Post ReplyReply Direct Link To This Post Topic: 970 extreme 3 ultra fast boot
    Posted: 13 Aug 2015 at 12:30am
My motherboard is Asrock 970 extreme3. i am using windows 10 pro 64bit in gpt format.

When i am trying to enable ultra fast boot mode from uefi, i get an error message 'The VBIOS of your discrete VGA card does not support UEFI GOP, so it can not support "Ultra Fast Boot" and "CSM Disable" '

my graphic card is Gigabyte gtx 650 ti 2Gb. on the latest vbios and supporting uefi gop. Gigabyte support said  "After confirmed, GV-N65TOC-2GI (rev. 1.0) F11 BIOS is already UEFI BIOS. About the issue you mentioned, we suggest you to contact your motherboard manufacturer and see if there is any setting in BIOS you need to adjust."

motherboard bios version is 1.80, which is the latest available from asrock website.

Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 14 Aug 2015 at 11:48am
I had to update the VBIOS of an EVGA GTX 650 video card before I could use Ultra Fast boot with Windows 8. That was a while ago now, and their VBIOS update worked fine, but that was with an ASRock Z77 (Intel) board.

Given the error message you are seeing, that seems to be a Gigabyte problem, but I'm not 100% certain.

There is a Beta BIOS for your board for use with AM3 processors and secure boot, which has the same requirements as using Ultra Fast:

http://www.asrock.com/mb/AMD/970%20Extreme3/?cat=Beta
Back to Top
panabesk View Drop Down
Newbie
Newbie


Joined: 13 Aug 2015
Location: Greexe
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote panabesk Quote  Post ReplyReply Direct Link To This Post Posted: 15 Aug 2015 at 2:22am
Is there any changelog for the beta bios ? i didn't find any. my CPU is amd fx 6300
Back to Top
WKjun View Drop Down
Newbie
Newbie


Joined: 17 Aug 2015
Status: Offline
Points: 56
Post Options Post Options   Thanks (0) Thanks(0)   Quote WKjun Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2015 at 9:23pm
Well, that's a mess and hard to say. At first I would have suspected the VGA BIOS. If they say UEFI is fully supported, then maybe there is a MB BIOS bug. Actually, the older the hardware, the crapier UEFI implementation gets. Especially around the AM3+ platform. A newer FM2+ board with an AMD APU boots Win7 the hell of a lot faster, even without UEFI partition!
You can see how slow or fast it boots if you start the MSCONFIG tool and enable "OS boot information" at the Boot tab. On AM3+ the lines with loaded drivers can be seen for a while with MBR partition (Legacy), it's okay but quiet slow. But with a GPT partition (UEFI) it needs at least double the time. While on FM2+ I not even see one line with a MBR partition, so no use to bother with UEFI and Win7 there. The BIOS implementation is vital for proper UEFI support and all components need to be alright.
My AM3+ boards with Radeon 7950 & 280X do not allow me to use CSM with VGA UEFI enabled. It has to be Legacy.
If there is no update or the update does not add the required feature, you have to enable CSM and set just "Launch Video OpROM Policy" to "Legacy", but keep in mind, you do not have to abandon UEFI/GPT boot compeltely because of that.
 
Do you have other VGA cards to test how the MB reacts?
You could open an official support ticket at ASRock Support. But I still think the VGA card is the problem.

Edited by WKjun - 18 Aug 2015 at 9:53pm
Back to Top
panabesk View Drop Down
Newbie
Newbie


Joined: 13 Aug 2015
Location: Greexe
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote panabesk Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2015 at 9:29pm
this is NOT graphic card problem. my gpu supports uefi gop and in another pc i can use ultra fast boot mode with my graphics card
Back to Top
WKjun View Drop Down
Newbie
Newbie


Joined: 17 Aug 2015
Status: Offline
Points: 56
Post Options Post Options   Thanks (1) Thanks(1)   Quote WKjun Quote  Post ReplyReply Direct Link To This Post Posted: 18 Aug 2015 at 9:55pm
Maybe I overread it, but then you clearly have a MB BIOS problem. I suggest an official ASRock support ticket.
 
PS: I've edited my last post meanwhile, because I went uncertain after all and I've remembered much more about my experiences while I typed.
Back to Top
panabesk View Drop Down
Newbie
Newbie


Joined: 13 Aug 2015
Location: Greexe
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote panabesk Quote  Post ReplyReply Direct Link To This Post Posted: 19 Aug 2015 at 8:54pm
i can't find anything like  'CSM' or  "Launch Video OpROM Policy" in uefi settings ...

is there any other naming of these ?
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 23 Aug 2015 at 3:13pm
Does your BIOS have a Secure Boot setting?

Secure Boot will (must) disable CSM in order to work. If you don't have a Secure Boot option in your BIOS, I doubt you would have a CSM option.

BTW, if you set Fast Boot to Ultra Fast the CSM option will be removed from the BIOS/UEFI options. At least that is how it works on some other ASRock boards. A potential bug in the UEFI may not be setting CSM to Disabled before it is removed.

So set Fast Boot to Disabled, and you might even need to save and exit the UEFI and go back in again to find the CSM option. If still no CSM and you have Secure Boot, disable Fast Boot, and then enable Secure Boot. Restart into the UEFI, and then set Fast Boot.

The CSM option is normally at the very bottom of the Boot or Advanced screen. It is easy to miss.
Back to Top
panabesk View Drop Down
Newbie
Newbie


Joined: 13 Aug 2015
Location: Greexe
Status: Offline
Points: 9
Post Options Post Options   Thanks (0) Thanks(0)   Quote panabesk Quote  Post ReplyReply Direct Link To This Post Posted: 23 Aug 2015 at 6:20pm
there secure boot option in my uefi. i've tried changing it to enable , but nothing happens. If i disable fast boot , the csm option appears in acpi settings , but nothing changed . i still get the same error message
Back to Top
parsec View Drop Down
Moderator Group
Moderator Group
Avatar

Joined: 04 May 2015
Location: USA
Status: Offline
Points: 4996
Post Options Post Options   Thanks (0) Thanks(0)   Quote parsec Quote  Post ReplyReply Direct Link To This Post Posted: 24 Aug 2015 at 2:23am
Well, if you are sure that your video card is GOP compatible (as you said you verified on another board), and you have CSM Disabled and Fast Boot set to Ultra Fast, that would seem to be potentially a UEFI/BIOS issue. Unless something related to Windows 10.

I've never seen any posts about your board and problems with Ultra Fast boot, so it is difficult to know exactly what is happening.

Question, what is the other board that your video card worked fine with Ultra Fast boot?

Also, what video interface are you using on your video card? HDMI, DVI, VGA?
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.111 seconds.