ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - X370 Killer SLI huge volt. drop, impossible to OC
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X370 Killer SLI huge volt. drop, impossible to OC

 Post Reply Post Reply Page  <1 234
Author
Message
augustobotossi View Drop Down
Newbie
Newbie
Avatar

Joined: 19 Jan 2018
Location: Brazil
Status: Offline
Points: 17
Post Options Post Options   Thanks (0) Thanks(0)   Quote augustobotossi Quote  Post ReplyReply Direct Link To This Post Posted: 19 Jan 2018 at 12:10am
Originally posted by adsaidler adsaidler wrote:

Originally posted by zlobster zlobster wrote:

Originally posted by adsaidler adsaidler wrote:

Originally posted by chainsaw chainsaw wrote:

if you can exchange the MOBO for a launch Rev. you can get LLC. Sad that ASRock is removing features on new revisions. When we look up reviews about the mobo they are often from early in the release cycle. when asrock removes features as time goes on it really does a dis-service to the end users.

That is the problem. I feel extremely mislead.


Welcome to the ASRock club! LOL

I'll keep this in mind when time comes to purchase my next motherboard, or give advice to friends.

However, the price was extremely good at black friday, making it cheaper than lots of B350 boards, so I still feel like I got a lot o value for the money invested.

Looks are awesome too on my black and white build! :D

We are kind in the same boat then, I got this board at BF too and I am seeing the same thing. I am running my R7 1700 @3,6Ghz 1.1875V, but when stress testing, HWINfo shows a max Vcore of 1.131V. 0.044 is marginal, I know, but LLC would be put to some good use right now. I am using the stock cooler, so I am taking OC slow right now.
Back to Top
augustobotossi View Drop Down
Newbie
Newbie
Avatar

Joined: 19 Jan 2018
Location: Brazil
Status: Offline
Points: 17
Post Options Post Options   Thanks (0) Thanks(0)   Quote augustobotossi Quote  Post ReplyReply Direct Link To This Post Posted: 19 Jan 2018 at 12:17am
Originally posted by wardog wardog wrote:

Busy at home and late to the game here but............

Two new X370 Killer SLI/AC BIOSes just released on Jan 16 2018.

Must be done in order.

3.50 FIRST

Then 4.50



4.50: AGESA PinnaclePI-AM4 1.0.0.0



I upgraded but returned to 3.40. I had several issues with this new RAM. I was running my RAM micron @2933Mhz 1.275V, but with this new BIOS it responded with continuous shot beeps until I powered the system holding the power button. Also, if doing OC with p-states is your thing, you must chose the AMD CBS OC option. However, that closes the XMP options too and OCing the RAM gets complicated. And, the other situation I found is that the mobo gets the RAM voltage resetting to 1.20V (im my case), so it's not helping at all.
Back to Top
 Post Reply Post Reply Page  <1 234
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.133 seconds.