ASRock.com Homepage
Forum Home Forum Home > Technical Support > Intel Motherboards
  New Posts New Posts RSS Feed - X270 Fatal1ty ITX not seeing M.2 Adata XPG SX8000
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

X270 Fatal1ty ITX not seeing M.2 Adata XPG SX8000

 Post Reply Post Reply
Author
Message
Squirrlz View Drop Down
Newbie
Newbie


Joined: 21 Jan 2018
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote Squirrlz Quote  Post ReplyReply Direct Link To This Post Topic: X270 Fatal1ty ITX not seeing M.2 Adata XPG SX8000
    Posted: 21 Jan 2018 at 9:19pm
So, this board comes with an M.2 slot on it, which is great. I found an NVME SX8000 512gb for a decent price and popped it in per the manual, but I don't see it listed in the BIOS anywhere. Not in Storage Configuration, not in System Browser. I've set the Storage OpROM to UEFI Only as suggested by what I've found in Googling the issue, but it still doesn't show up. I've pulled the SX8000 from the M.2 slot and reseated it to make sure it's not loose, and no dice. I double checked the M.2 storage support list on the support page for this motherboard, and the SX8000 is listed as compatible. I used a static wristband to install it; I'm pretty particular about clean builds.

Since this is relatively new tech I'm unsure where to go from here. In some other posts I've found from Google it seems there can be a lot of hoops to jump through to get NVME drives to work, but none that seem to apply to a modern motherboard like this (they date several years old for the most part).

One thing I tried was the Windows Install trick, which is to put the Intel RST drivers on a Windows Install USB and load them up on install start, still no drive. I tried switching to raid mode and enabling "RST Remapping" in the BIOS since that seems to be the only M.2-related option then doing the Windows Install trick again, still no drive. I tried using Disk Management in my current OS to see if I can find it there, still no drive.

I am at a loss here. Does anyone know what to do? This couldn't be because I have a dedicated GPU in the PCIe slot, could it? I would assume the manual would mention something like that, and I'd hope on a gaming board like this the M.2 slot would have its own PCIe lane.

I am on BIOS 2.40 for the board, so it is the latest BIOS revision.
Back to Top
ASRock_TSD View Drop Down
ASRock_Official
ASRock_Official


Joined: 20 Mar 2015
Status: Offline
Points: 8622
Post Options Post Options   Thanks (0) Thanks(0)   Quote ASRock_TSD Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jan 2018 at 10:31am

Dear Squirrlz,

 

Thank you for choosing ASRock.

 

Regarding your case, we have built a system in our lab, SX8000 can be recognized properly.

 

We provide some suggestion to verify.

1.       Please install your M.2 SSD to another system to check if this SSD works fine.

2.       Please install another M.2 SSD on your motherboard to check if the M.2 slot works fine.

 

Thank you!

Yours truly,

ASRock TSD

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.156 seconds.