ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Taichi x370 Windows 7 keyboard/mouse not working
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Taichi x370 Windows 7 keyboard/mouse not working

 Post Reply Post Reply Page  <12
Author
Message Reverse Sort Order
aleks View Drop Down
Newbie
Newbie


Joined: 02 May 2018
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote aleks Quote  Post ReplyReply Direct Link To This Post Posted: 02 May 2018 at 5:44am
Hello everyone,

I'm using a Ryzen 7 1800x combined with a Taichi x370 motherboard and I'm running Windows 10 on my M.2 drive. So far so good. I have another regular SSD on which I would like to install Windows 7 as a second OS. Now there are problems. I have tried installing Windows 7 from a USB drive, but as soon as the USB drive is initialized, the mouse and keyboard stop working and I can not even install the OS. After some research I figured that there's a USB patcher for the AM4 boards including the Taichi x370 on the Asrock website, and I included the necessary drivers in my Windows 7 installation files. Now I was able to install Windows using mouse and keyboard, and everything seemed fine.

However, as soon as Windows 7 booted on its own, the keyboard and mouse drivers apparently stopped working and I could not enter a user name. A friend borrowed me a PS2 keyboard so I successfully made it through the setup process. Using my HDD I was able to supply my new OS with the necessary LAN driver and finally I could start running updates. The updates were installed, but upon restart Windows gave me a popup message saying "Unsupported hardware", saying my processor is designed for the latest version of Windows and I would miss out several security updates because of that.

The main issue now is that my mouse and keyboard plugged in USB 3.0 ports are not recognized. I've tried running Windows Update again but so far to no avail, the message keeps popping up. Does anyone know how to bypass this issue? Considering Windows 7 is still officially supported by Windows I was surprised that apparently it was ditched by AMD. All the more confusing is it to me that Asrock supplies Windows 7 USB drivers for AM4 boards but these drivers stop working as soon as the OS is installed?

Specs:
AMD Ryzen 7 1800x
Asrock Taichi x370
OS: Windows 7 Professional N SP 1

I would really appreciate some help. I don't really know what to try anymore.

aleks
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.219 seconds.