ASRock.com Homepage
Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - A320M-HDV -SSD - 960 EVO 250 SAMSUNG
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

A320M-HDV -SSD - 960 EVO 250 SAMSUNG

 Post Reply Post Reply
Author
Message Reverse Sort Order
kerberos_20 View Drop Down
Senior Member
Senior Member
Avatar

Joined: 06 Dec 2017
Location: czech republic
Status: Offline
Points: 3627
Post Options Post Options   Thanks (1) Thanks(1)   Quote kerberos_20 Quote  Post ReplyReply Direct Link To This Post Topic: A320M-HDV -SSD - 960 EVO 250 SAMSUNG
    Posted: 07 May 2018 at 3:58pm
Quote

How to fix Windows 10 internal hard drive showing as removable in Registry?

Step 1. Right-click the Start button in Windows 10. On the Power Users menu, choose Command Prompt (Admin) to open a command prompt with administrator privileges.
Step 2. In the command prompt window, type the following command in hit Enter: devmgmt.msc
Step 3. Under Disk Drives, identify the SATA device you would like the inbox driver to consider internal and open properties for this device by right-clicking and selecting Properties.
Step 4. Note the bus number from the properties overview.
Type the following command in the previously opened command prompt and hit Enter:

reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device" /f /v TreatAsInternalPort /t REG_MULTI_SZ /d x
Where x corresponds to the Bus Number you noted in step 4.

Step 5. Reboot PC.

Back to Top
natof View Drop Down
Newbie
Newbie


Joined: 07 May 2018
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote natof Quote  Post ReplyReply Direct Link To This Post Posted: 07 May 2018 at 2:57pm
Hello

i have a A320M-HDV with a RYZEN 5 2400.
I connected a SSD 960 EVO 250 SAMSUNG on the Ultra M.2
in the UEFI SETUP the 960 EVO is detected as M2_1(pcie)
sata controllers : enable
sata mode :AHCI MO
sata hot plug : disabled
i have 3 hdd connected and a cd rom drive  on sata 1,2,3,4
i have w10

my SSD 960 EVO 250 SAMSUNG is detected as an external  peripheral

 i have the window " eject it before disconnecting"Cry
how can i fix that Ouch

hope all is clear , i'm french and i know that my english is not so good

thank you by advance SmileClic droit pour décaler
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.137 seconds.