Forum Home Forum Home > Technical Support > AMD Motherboards
  New Posts New Posts RSS Feed - Hard drive
  FAQ FAQ  Forum Search Search  Events   Register Register  Login Login

Hard drive

 Post Reply Post Reply
zoeyemars View Drop Down

Joined: 14 Jul 2018
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote zoeyemars Quote  Post ReplyReply Direct Link To This Post Topic: Hard drive
    Posted: 14 Jul 2018 at 12:07pm

Hi, I'm not a native English speaker, please sympathize for my poor 

 Im having a problem about hard drive.
I redid my water cooling loop today, nothing special, just a normal replacement. Got it done, now my damned MoBo won't detect ANYTHING in term of hard drives. I have tried
Replacing cables
Removing all cables, powering up while unplugged, and replugging them back in
Different SATA slots
Different Cables
New power cables
Check SATA Controller and Storage Configs(Shows nothing)
BIOS and UEFI are up to date
Tried all 3 hard drives with different power and SATA cables, all to nothing
MoBo:ASRock Fatal1ty X370 Professional Gaming
CPU:Ryzen 1700x
RAM: DDR4 24gb
GPU: 1080ti
I have 2 2TB HDDs and 1 256gb SSD. I am at a total loss

Edited by zoeyemars - 14 Jul 2018 at 12:08pm
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.04
Copyright ©2001-2021 Web Wiz Ltd.

This page was generated in 0.125 seconds.