Print Page | Close Window

DTSMA passthru problem Z170 Gaming-ITX/ac (solved)

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=1022
Printed Date: 24 Apr 2024 at 8:26am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: DTSMA passthru problem Z170 Gaming-ITX/ac (solved)
Posted By: 10k
Subject: DTSMA passthru problem Z170 Gaming-ITX/ac (solved)
Date Posted: 14 Oct 2015 at 7:51am
Hello, I have just bought an Asrock Fatal1ty Z170 Gaming-ITX/ac for use in HTPC with a new 4K OLED supporting HDMI 2.0 and 4k resolution at 60hz.

I have the PC hooked up via HDMI2 to my Marantz nr1605 receiver which is hooked up to my LG 65EF9500 OLED at 4k resolution 60hz refresh rate.

My problem is that in windows sound properties it correctly shows my marantz avr as supporting DTS-HD and DTS-MA formats, however when I try and pass those formats to the receiver I get no sound. 

This setup worked previously when I had an NVIDIA gtx950 driving things so I suspect that there is potentially something wrong with the asrock hdmi implementation.

Does anyone have any idea or solution?

Thanks



Replies:
Posted By: 10k
Date Posted: 18 Oct 2015 at 5:17am
In case anyone gets here from Google.  I did further testing and can confirm that the HDMI2 (hdmi 2.0) port on the Asrock Fatal1ty Z170 Gaming ITX/ac motherboard does not support hd audio format passthrough (dts-hd dolby TrueHD). 

I connected another HDMI cable to the HDMI1 port and set windows to use that as the default audio device.  HD audio passthrough began working immediately after that.

Hopefully this is something Asrock can address with a future firmware update.


Posted By: mrlanz
Date Posted: 01 Nov 2015 at 8:42pm
I'm interested to know about your video setup. Do you have 4k@60Hz with deep color working? And if so did you updated the MC2800 firmware to make it work? And finally how did you verify that it was running deep color?


Posted By: 10k
Date Posted: 04 Nov 2015 at 3:54am
Yes, I updated firmware updated to latest when I got the board last month and had not tried 4k60hz before the update.  If 4k 60hz rgb 4:4:4 is working, then deep color is working as it can not work otherwise.

As an aside, I found the spec sheet for the MDCP2880 chip that provides HDMI 2.0, and DTS HD and Dolby TrueHD are absent from the list of audio formats supported
http://www.megachips.us/products/documents/MCDP28x0_Databrief.pdf




Posted By: berry131
Date Posted: 06 Sep 2016 at 2:30am

@10k: did send you a pm about the HD passtrough issue




Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net