Print Page | Close Window

Beebox N3150 2.4Ghz wireless network issues

Printed From:
Category: Technical Support
Forum Name: HTPC&Gaming Barebone&Others
Forum Description: Question about HTPC&Gaming Barebone&Others
Printed Date: 02 Mar 2024 at 8:56am
Software Version: Web Wiz Forums 12.04 -

Topic: Beebox N3150 2.4Ghz wireless network issues
Posted By: bigwest
Subject: Beebox N3150 2.4Ghz wireless network issues
Date Posted: 15 Oct 2015 at 12:41am
I've been trying to fix an issue for a relatives N3150 Beebox where by it does not connect to their wireless network or connects at very slow speeds.  I took it home and tried it on my wireless router which has dual-band 2.4Ghz and 5Ghz networks. It was able to connect to the 5Ghz network without issues. It is able to see the 2.4Ghz and prompts for the security key when connecting but does not ever obtain an IP address.

I have a N3000 beebox myself so I tried taking the 8821AE wireless card from my N3000 and swapping it with the card in the N3150. The problem persisted. My N3000 connects to both the 2.4Ghz and 5Ghz networks without any issue which would make me think this is an issue that affects only the N3150 model or just this 1 particular N3150.

I thought it might be the Windows 10 drivers so tried installing Windows 7 but the same issue occurs with both the drivers from the asrock website and newer ones installed via windows update.

Has anyone else experienced wireless issues on their N3150 ?

Posted By: SuperDaniel
Date Posted: 15 Oct 2015 at 1:13am
I have only a 2,4 ghz wlan and I have no problems

Posted By: bhare
Date Posted: 15 Oct 2015 at 8:33am
I am having the same kind of issue.
I have a new Beebox 3150 barebones with 8GB RAM and 128GB mSSD. I have installed Linux Mint 17.2 Rafaela. The Beebox sees my wireless network as well as other networks in range. When I tell it to connect to my network, it tries to connect for a while and then it reports: "Disconnected from Network - You are now offline". After this, it no longer shows my network in Network Connections (but it still sees all the other networks it found before). After I disable wireless and then enable it again, it sees my network again, but still will not connect.
I would be grateful for any suggestions or insights into my problem.

Posted By: bigwest
Date Posted: 16 Oct 2015 at 2:17am
I've just tried booting in to an ubuntu live usb image on a N3000 and N3150. 

On the N3000 I could connect a browse the internet fine on both 2.4Ghz and 5Ghz networks.

On the N3150 I could connect and browse on the 5Ghz network. I managed to connect once to the 2.4Ghz network, but ping times to the router were very high and I could not browse the internet at all. I disconnected and try to connect to the 2.4Ghz network again but failed to pick up an IP address at all.

Maybe the N3150 is creating some sort of interference for the wireless card on 2.4Ghz networks? Any comment from Asrock ?

Posted By: onum
Date Posted: 17 Oct 2016 at 3:59pm
Hi, I have exactly the same problem (and a different bizzare issue) on a J3160 based Beebox. It has the Realtek 8821AE ac WLAN card but my network is 2.4GHz wireless n only.

There aren't many options in the advanced properties tab and all I've altered is Wireless mode to b/g/n.

It connects to my network OK but the wireless performance is terrible, dropping to dial-up type speeds eg 0.2Kb/s.

However, if I remove the lid of the beebox the speed is much higher (about half of what I get with a laptop that has a bgn wlan card). Now I am operating the box with a mechanical hdd so JIC it was part of the problem I detached the drive and loosely put the lid back on and got the same poor performance.

The bizzaro problem is that I get strange random noises from the box, mostly short shrill beep type noises or clicks or something hard to describe. It almost sounds like the HDD heads doing strange things.

However these completely stop if I Disable the WLAN card (hmmm) or run the box with the lid off(!)

When I described this problem to Asrock tech support (before I discovered the link to the WLAN card) they told me to RMA it immediately Ermm

I'd hate to do that as I quite like it otherwise and I've already sent a Brix back for having iffy USB ports. However terrible wifi is a pretty fundamental problem.

I guess the only other thing to investigate is the positioning/mounting of the aerial leads but they go behind the mobo so don't want to get into that if I'm going to end up returning it.


Posted By: onum
Date Posted: 18 Oct 2016 at 2:08am
" rel="nofollow - Ok, I've done some additional testing by swapping around the WLAN cards from the Beebox and the laptop.

In the the laptop both cards perform the same and I get my full network speed.

In the Beebox, both cards perform as badly as each other with same differential with the lid on/off.

I also moved the beebox to the same room as the router and got about a 50% gain - as long as the lid was off. With the lid loosely on top the performance again plummeted.

I think it's safe to assume the beebox case is significantly attenuating the 2.4GHz signal - incredible if it's a fault across the range.

So what to do? fit an external antenna, get a USB Wifi dongle or return the item as faulty I guess.

Edit: I forgot to add that despite the problems, the WLAN signal quality graphic always showed a full strength signal Confused

2nd Edit: I tried a stubby (20mm) external antenna. As I was still in two minds about returning it I didn't drill any holes for installation I just plugged  it in  and rested it on the edge of the case (the cable was too short for placing it further away). There was a slight improvement in connection speed (with the lid off) as soon as I put the lid on - and this is just resting it on top - I got my full connection speed.

Clearly the unit is generating interference internally that's killing 2.4GHz connectivity. "Fortunately'' the case can contain the interference allowing external antenna's attached to the case to work properly - if you're happy with that of course.

I have decided to return it for a refund as although I'd be comfortable adding the external antenna the unit also has some random POST issues where it sometimes freezes or takes a long time to POST.

So that's two NUC's down.... Ouch

Posted By: dimitrieq
Date Posted: 03 Feb 2017 at 10:32pm
" rel="nofollow - Hello,

I have the same problem t is able to see the wifi networks and prompts for the security key when connecting but does not ever obtain an IP address.
I formatted the machine and verified that with linux the wifi card works perfectly. So I went back to formatting and installing windows 10 without updates and it continued to work fine with no problems. After updates from windows 10 it stopped working again. Which leads me to say that there is some incomptiblity with some of the updates of windows 10. anyone already have a solution to this case?

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -