Print Page | Close Window

How to turn off RGB LEDs when PC is off?

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=10284
Printed Date: 15 Apr 2024 at 11:29am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: How to turn off RGB LEDs when PC is off?
Posted By: galapogos
Subject: How to turn off RGB LEDs when PC is off?
Date Posted: 30 Nov 2018 at 9:01am
Hi,

Just assembled a PC with addressable LED light strip, and with a mouse that has LED lights. These lights stay on even when the PC is shut down. I was able to get the mouse lights to turn off by enabling S5 sleep in BIOS, but the addressable LED remains on. How do I turn these off as well?

Motherboard is a Fatality B450 Gaming ITX/ac



Replies:
Posted By: seabird
Date Posted: 07 Mar 2019 at 11:22pm
bump...i have the same problem and am looking for a solution.


Posted By: Dominik
Date Posted: 15 Mar 2019 at 8:38pm
I don't have the same motherboard as you (mine is b450m pro4), but I had the same issue. I enabled the Deep Sleep option in the bios in Advanced\South bridge configuration and it worked. In the bios of this motherboard, this option can be enabled or disabled (there is no enabled in S5). With enabled, the addressable led strip turns off and there is no more current in the USB ports a few seconds after the computer shuts down.


Posted By: seabird
Date Posted: 23 Mar 2019 at 11:17pm
thanks for this....unfortunately just tried it and it still does not work. what mobo driver are you using? thanks for replying


Posted By: Dominik
Date Posted: 24 Mar 2019 at 8:47pm
The version of my bios is P2.00. The line Microcode Update is 800F82/800820B. The Agesa version I have is Pinnacle PI-AM4 1.0.0.6.

I just saw that there is a new update for my bios (version 3.10), but I didn't updated yet.


Posted By: madeasman89
Date Posted: 24 Mar 2019 at 10:03pm
I'm having the same issue. It happened once I updated to the most recent version and I dont know how to go back to the previous version. They wont turn off in sleep mode or shut down. I have X470 SLI/ac MB with most recent bios update 1.90 I tried the enabling Deep Sleep in south bridge like was previously stated but it did nothing. I really dont want to have to keep shutting off the switch of my PSU just so the lights turn off. Someone please help fix this.


Posted By: xhue
Date Posted: 24 Mar 2019 at 10:49pm
Did you try updating the RGB LED firmware from Windows?


Posted By: Dominik
Date Posted: 24 Mar 2019 at 11:01pm
I just remembered something else. On my motherboard (B450m Pro4), It seems there is a nuvoton chip that handles the lights. I think the version of Polychrome RGB software (and the version of the firmware of the nuvoton chip) influence the behavior. I few months ago, I had the Deep sleep option disabled, I had the Polychrome RGB software version 1.0.27 and, when the computer goes to sleep or shuts down, the lights turn off. When I updated to the Polychrome RGB software version 1.0.35, the behavior changed. The lights were always light and I had to change the Deep Sleep option to make them turn off.

Perhaps you could try to downgrade to Polychrome RGB version 1.0.27? I found a working downloadable link ([URL]http://asrock.pc.cdn.bitgravity.com/Utility/RGB/PolychromeRGB(v1.0.27).zip[/URL]) on the thread [URL]http://forum.asrock.com/forum_posts.asp?TID=10436&title=asrock-polychrome-rgb[/URL]


Posted By: xhue
Date Posted: 24 Mar 2019 at 11:26pm
Fingers crossed! Let us know how it went.


Posted By: MadeAsMan
Date Posted: 25 Mar 2019 at 12:14am
When I updated to the newest version (1.0.35) the firmware updated automatically upon running the program. All my Asrock BIOs, software and firmware is up to date currently. I will try that link for the 1.0.27 version when I get home and see if that resolves the issue. Can we expect Asrock to release another update anytime soon that would fix this problem?


Posted By: xhue
Date Posted: 25 Mar 2019 at 1:26am
Well, yes. We can expect ASRock to fix this.

Will they fix it? That, I don't know.


Posted By: madeasman89
Date Posted: 25 Mar 2019 at 5:17am
So installing a previous version didnt fix the problem either =(


Posted By: madeasman89
Date Posted: 25 Mar 2019 at 6:06am
I tried shutting off the RGB in my BIOs and unplugging rgb headers, and uninstalling all asrock software, then restarted computer, shutoff computer again to plug headers back in, went back in BIOs to turn RGB back on, did not reinstall asrock software, but tried to sleep mode and shutdown and the lights still stay on. Im all out of ideas.


Posted By: Dominik
Date Posted: 25 Mar 2019 at 7:05am
When you installed the Polychrome RGB software version 1.0.27 and you started the program, did you noticed if the program installed the firmware for the nuvoton chip before it shows the controls for the lights? You should had a message similar to "Updating RGB LED Firmware".
If not, you could try to do it manually. You should have the file nu51_2.07 and the executable wICPFLASH.exe in C:\Program Files (x86)\ASRock Utility\ASRRGBLED\Bin\. To update the firmware:
1) start an administrator console
2) go to the bin folder. (cd "C:\Program Files (x86)\ASRock Utility\ASRRGBLED\Bin\")
3) Launch the program (wICPFLASH.exe /File=nu51_2.07)

If it still doesn't work, I think your only hope is that ASRock publishes a new version of their software, or perhaps someone else would found a solution for your motherboard?


Posted By: seabird
Date Posted: 25 Mar 2019 at 7:10am
couldn't get mine working either... tried version 1.0.27. btw i have the b450 pro4


Posted By: S0M1
Date Posted: 01 Apr 2019 at 11:12pm
Have the same problem. Hope it will be patched soon


Posted By: madeasman89
Date Posted: 07 Apr 2019 at 9:56am
Anyone figure this fix out yet?


Posted By: chrispru
Date Posted: 16 Apr 2019 at 7:17am
I just completed my first build for my son and was having the same issue with one strip of lights on the Phanteks 350X case staying on when turning the computer off. I installed the A-tuning app and changed the setting to power saving mode. This caused the rgb lights to go off. Hope this helps.


Posted By: madeasman89
Date Posted: 16 Apr 2019 at 11:21am
That didn't work. A-tuning app is separate from the Polychrome app so Idk how that would have worked for you.


Posted By: zhaofonk
Date Posted: 16 Apr 2019 at 3:57pm
I also have the same problem (the RGB on my B450M Steel Legend won't turn off). What I also noticed is an small electric buzzing sound when the PC is sleeping/turned off, which wasn't there before I installed Polychrome (at least I never noticed). I don't know what that means...

I saw on another thread that this behaviour was apparently intended and that they would add an option in the BIOS to turn it off...



Posted By: XmanSE
Date Posted: 18 Apr 2019 at 8:51am
Yesterday i updated the polychrome software in my x470 taichi from 1.0.27 to the newest 1.0.38, the software did update the firmware when i started and everything was ok until i turned off the pc.

I noticed an small electric buzzing sound, and the rgb light of the board wont turned in off , so i decided tu turn off the psu switch and obviously all turn off.

Today i enabled the deep sleep and rgb light turn off 1 o 2 seconds after turned off the pc.

So the problem is in the firmware update of the rgb lights, because with the latest version that i had installed this never happend, always had turned off completely without enable deep sleep in bios.

-------------
X470 Taichi | Ryzen 9 3900X | 8x2 GSkill Trident Z RGB | Asus Strix RTX 2080ti | Samsung 970 Evo+ | EVGA 750 GQ


Posted By: zhaofonk
Date Posted: 18 Apr 2019 at 4:19pm
I contacted the Asrock support and the issue has been resolved! They sent me a new BIOS (for B450M Steel Legend version 2.01) which included the option
Advanced > South Bridge Configuration > Turn On LED in S5 > Disabled.
If someone has the same board maybe I can send the BIOS to you, for the others, from Asrock support: "This BIOS solution will be phased into all ASRock motherboard new BIOS versions." Just be patient!


Posted By: JackHadar
Date Posted: 02 May 2019 at 4:10am
I have the exact same mobo, and I also sent asrock a message, but they didn?™t respond yet... Where did you contact them, and how long did it take for the replay?


Posted By: zhaofonk
Date Posted: 02 May 2019 at 4:22am
I contacted ASRock Europe, they only took a day to reply, but the problem was solved 4 days later (they had to contact Asrock Taiwan to get the new version of BIOS).


Posted By: JackHadar
Date Posted: 02 May 2019 at 9:39pm
Thx, I got the new bios also, and it works great!!


Posted By: Puppet3187
Date Posted: 03 May 2019 at 9:18am
Where can I find the new bios update? My lights on my mobo don't turn off either.


Posted By: chrismarshall3
Date Posted: 03 May 2019 at 11:42am
Mine is the same problem.
Have the latest Bios off the website x470. 3.20

They dont reply to emails for weeks. If they do they just write ridiculous questions with no offer to help. Joke of a company.


Posted By: 1crimsonking1
Date Posted: 08 May 2019 at 12:01am
can i have the bios? i have the same mobo and rgb still stays on no matter what i do :/


Posted By: zhaofonk
Date Posted: 08 May 2019 at 12:11am
Send me a message with your email adress and I can send it to you


Posted By: 1crimsonking1
Date Posted: 08 May 2019 at 3:32am
done :P i hope it works


Posted By: Puppet3187
Date Posted: 10 May 2019 at 1:07pm
I sent you a message zhaofonk. Thanks for your help!


Posted By: nc223
Date Posted: 12 May 2019 at 7:00pm
I had the same problem and could solve it without updating to a new bios.
I am currently using Uefi-Version 2.00 and the latest RGB-Software for Win10.

In the Southbridge-Configuration I enabled the S5-Powersaving-Mode. First it didn´t work, but then I disabled the Fastboot-Option in the Energy-Settings in Win10.

Now it works, 3 seconds after shutdown the LEDs turn off.



Posted By: artursf
Date Posted: 11 Nov 2020 at 7:06am
Windows 10
1. Power Options
2. Choose what the power buttons do
3. Change settings that are currently unavailable
4. Turn off Fast Startup
5. Save changes

https://www.youtube.com/watch?v=wb15oUXiYnM



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net