Print Page | Close Window

Motherboard not lighting up when PSU is switched o

Printed From: ASRock.com
Category: Media&User's Review
Forum Name: Intel Motherboards
Forum Description: ASRock Intel Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=10340
Printed Date: 27 Jul 2021 at 10:46am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Motherboard not lighting up when PSU is switched o
Posted By: puksometron
Subject: Motherboard not lighting up when PSU is switched o
Date Posted: 07 Dec 2018 at 3:39pm

0
down vote
favorite
I have an ASRock Fatal1ty Z370 Gaming K6 motherboard which is a quite recent board. While I was using my computer, everyone shut down rapidly. At first, I thought it was a power blackout in the house but the other appliances seemed to work. I then realised that the computer was refusing to boot up.

I thought that it was the power supply but after removing it, I was able to successfully power on an older computer that drew less power. The power supply is a 750W Corsair RM750X. I disconnected all hard drives, M.2 SSDs and memory DIMMs and decided to test the motherboard with the CPU and power supply separately. A video of the problem is available [URL=https://drive.google.com/open?id=1ASdFauVlQ85Elep4D0E96msVYf7qJOLS]here[/URL].

As soon as I flick the switch on the power supply, the motherboard lights up briefly before dying again. The on-board power button also refuses to work. If it may help, the BIOS was updated a week earlier but updated perfectly fine since the computer was being used normally and functioning normally before this incident occurred. Any help would be greatly appreciated.



Replies:
Posted By: arso96
Date Posted: 12 Dec 2018 at 11:33am
Have you cleared the CMOS and tried with one stick of memory and in different slots?

Disconnect everything except one stick of memory, PSU, CPU, and hook up the monitor to the onboard GPU.


Posted By: puksometron
Date Posted: 13 Dec 2018 at 2:42pm
I have tried that. Still the same problem. As soon as I connect the PSU, the lights turn on and then just die again. Power button doesn't turn on the system, with or without a CPU and memory. I can hear this buzzing sound from the sound card, where it says Creative Sound Blaster below the IO. I don't know what that means.


Posted By: RLGL
Date Posted: 13 Dec 2018 at 9:53pm
Are you trying to turn it on with the power button on the board or the button on the case? Try the one on the board.

-------------
Asrock Z370 Gaming K6,Intel i7 8700K,
Asrock x570 Taichi




Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net