Print Page | Close Window

Steel Legend RGB ultility not working

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=10951
Printed Date: 15 Jun 2024 at 4:29pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Steel Legend RGB ultility not working
Posted By: p3pijn
Subject: Steel Legend RGB ultility not working
Date Posted: 23 Feb 2019 at 10:31pm
I cannot seem to set-up the RGB in the ASRRGBLED application.

When I open the program it errors claiming:

"
Error 0xFFC

This ultility is not for this platform!
"

I have the Steel Legend B450m motherboard, with MASTERFAN MF120R A.RGB connected.

The leds are powered, and spew out cycling colors in what I understand we pc enthusiasts call "rainbow puke".

Thanks for the help!



Replies:
Posted By: p3pijn
Date Posted: 23 Feb 2019 at 10:33pm
After I click the message I get another error message:

"
ASRockRGBLed

Access violation at address 00461BC5 in module 'AsrPolychromeRGB.exe'. Read of address 00000000.
"


Posted By: p3pijn
Date Posted: 23 Feb 2019 at 10:40pm
Curiouser and curiouser...

When I go in the UEFI, and try to change the RGB colors there, weird things happen, red = blue and changing effects also change the colors. However, I to just be blue, and I am ok with that, for now.


Posted By: tiger1003
Date Posted: 20 Mar 2019 at 8:40am
Hello,

Could you solve it ?, the same thing happens to me with the same error, I have a RAM T Force RGB and the B450M Steel Legend.

Hopefully if you solve it, you can help others.

Thank you.


Posted By: Coletrain14
Date Posted: 29 Mar 2019 at 10:14am
I'm having the exact same issue! i have an antec ARGB 3+2+C kit with a fan controller. I can control the RGB effects of my fans in the UEFI but not the mobo lights. but polychrome is giving me the exact same error as this. Ive tried manually updating the program in the command prompt and it still wont work.
SOMEBODY PLEASE HELP!


Posted By: CDub0687
Date Posted: 31 Mar 2019 at 3:24am
Hello, I joined this forum just to reply to this. It seems the RGB software is hit and miss compared to the version of the software. I had to try several versions to get my working but now it controls my motherboard, Team Group Delta RAM RGB, 3 Thermaltake fans and the TT pump. I went with file version 2.0.4 and it didn't give me that error. Working good ever since.


Posted By: CDub0687
Date Posted: 31 Mar 2019 at 3:39am


Posted By: CDub0687
Date Posted: 31 Mar 2019 at 3:42am
If your referring to the nu51 file I don't think that actually updates the software just the firmware to the led controller.


Posted By: Series
Date Posted: 24 Apr 2019 at 11:01am
If you wouldn't mind, What Software are you talking about? How did you get it to work? I am having the same issue.


Posted By: CDub0687
Date Posted: 29 Apr 2019 at 8:11pm
What can I help to get done? What all have you done so far?


Posted By: dunkin_boy
Date Posted: 30 Apr 2019 at 7:17pm
I'm having quite the problem here, I think after updating the BIOS from the latest version 2.00, the lights won't even work. Even configuring it from the UEFI settings wont help. Anyone having the same problem here?


Posted By: CDub0687
Date Posted: 30 Apr 2019 at 8:28pm
What version of Polychrome are you using?


Posted By: dunkin_boy
Date Posted: 30 Apr 2019 at 9:34pm
I'm using 2.0.4.


Posted By: CDub0687
Date Posted: 30 Apr 2019 at 9:43pm
Thats the version I have currently. The nu_51 file is 3.02.


Posted By: dunkin_boy
Date Posted: 30 Apr 2019 at 9:56pm
I see. But what bothers me the most is that it wont even light up.


Posted By: dunkin_boy
Date Posted: 30 Apr 2019 at 10:40pm
Update:

I managed to make it work again by reflashing the firmware.



Posted By: Gigabit
Date Posted: 05 Jun 2019 at 1:48am
teach me to reflashing firmware.i fix it many way it not work.


Posted By: DanAnting
Date Posted: 23 Jun 2019 at 8:28am
I have the same problem is there a solution yet? I've tried the cmd stuff all it does is turn my leds off and back on. The utility error still pops up.


Posted By: phatphan
Date Posted: 23 Jun 2019 at 12:53pm
Same problem


Posted By: MonkeyJamboree
Date Posted: 23 Jun 2019 at 2:53pm
I also joined just to reply to this thread. I've had LOTS of issues with the Polychrome software. I first attempted to use version 1.0.38 as linked on [URL=https://www.asrock.com/microsite/PolychromeRGB/]https://www.asrock.com/microsite/PolychromeRGB/[/URL], the first google result for "Polychrome RGB." That did nothing but crash when it attempted to load. Then I dug through the support section for my motherboard and found version 2.0.4. That initially crashed when trying to install (because version 1.0.38 was still installed, and left over one of the Mslo* files). After removal of the entire "ASRock Utility" folder in the Program Files (x86) install folder, I was able to successfully install it. Upon running the first time, it downloaded and updated the RGB firmware (?), and seemed to work, to a point.

However, I still have issues with it. Sometimes the application still gives memory read errors when trying to start up (even though it's running with admin privileges). It doesn't actually save the component sync settings. Components seem to slowly have styles in their dropdown removed over time for some reason. Sometimes a third tab appears at the top randomly (Razer Chroma maybe? I can't recall what it is offhand).

General usability issues: There is no taskbar icon showing that the application is even open. The styles/patterns for the RAM are different from ones provided by the RAM manufacturer's application (T-Force Blitz). No advanced control or custom pattern capabilities. Many "modes" completely unavailable when trying to sync with the motherboard (Music, Wave, Spring, Stack, Cram, and Scan all greyed out). Name difference between "mode" on the motherboard settings tab and "style" on the component dropdown tab. Speed settings disappear when using component sync capability. Likely much more but that's just off the top of my head and looking at the application on a surface level.

PC Info - This is a brand new PC build, with several different RGB components, as follows:
Windows 10 Pro
ASRock B450M Steel Legend motherboard
Teamgroup T-Force Night Hawk Legend RAM (DDR4-3466) 2x8GB (gets RGB info through RAM slots)
Cooler Master MasterAir MA410M (uses the 5V pin header on the motherboard)
several other components without RGB support (4 SATA drives, PSU, case, fans, etc), but several I plan on getting or are on the way, none of which are ASRock products but say they have Polychrome RGB "support."
BIOS updated to the latest for my particular motherboard according to the support page (2.13A - Is there a reason it is not the same version as the Full ATX version of this board, which is v2.32?).

Please, fix this pile of garbage software. Had I known controlling RGB components was so problematic through this software, I would NEVER have purchased this motherboard to begin with.

Oh, and PLEASE fix the "feature" of the LEDs not turning off when the PC has been shut down completely in Windows. (Where exactly is the BIOS update that is supposed to fix this issue?)


Posted By: phatphan
Date Posted: 23 Jun 2019 at 9:03pm
First time move from Intel to AMD, i buy this mainboard.
And this is FUKCING garbage mainboard, garbage software.


Posted By: Oilan
Date Posted: 24 Sep 2019 at 12:42am
Same problem here.

I have ASROCK B450M Steel Legend Motherboard. RGB control is a nightmare.

My RGB HW:

ASROCK B450M Steel Legend
2x8GB G.Skill Trident Z F4-3200C14-8GTZRX
DeepCool Gamer Storm Castle 240 RGB AiO (addressable LED)
6x 120 MM SilentiumPC Sigma HP Corona RGB FANs (not on compatibility list)
(Also thinking about Sapphire RX 5700 XT Nitro+ (got a addressable RGB LED connector).

All parts selected carefully due to so called ASROCK Polychrome Sync compatibility!

Currently on the latest version of Polychrome Sync v2.0.27 Firmware v3.4.

ISSUES:

Onboard LED - Components Sync - Motherboard + DRAM = you lose about half of the effect options

Onboard LED - Components Sync - Motherboard + DRAM = after while DRAM is completely out of sync

ASROCK Polychrome Sync + Razer Synapse 3 - both apps setup to startup run + Chroma Connect ON = Polychrome Sync startup crash, runtime error

ASROCK Polychrome Sync + Razer Synapse 3 - both apps setup to startup run + Chroma Connect OFF = Works fine but you can?t sync Razer and ASROCK devices (THIS IS THE ONLY WORKING STATE)

DESCRIPTION:

Polychrome Sync can't fully coexist with Razer Synapse. Chroma Connect option needs to be turned OFF otherwise you?ll get into serious troubles.

If you want to try it then just install Polychrome Sync, Razer synapse, don't turn Chroma Connect ON and restart your computer. Now (after restart) you have Chroma Connect option in Polychrome Sync so you can turn it on. Also, check into Razer Synapse 3 that ASROCK connector is turned on (Connect - Devices). Now you can go to Razer Synapse Studio and you should see all your Razer RGB compatible devices with ASROCK RGB icon so you can setup your RGB effects to make it work for all components. But not for 100%.

In my case it was working for about 20 mins then everything de-synchronized, ASROCK controlled RGBs stopped in one color and RGB fans started flashing in between two colors. Razer Devices runs fine so no problem here.

- Rebooted computer and ASROCK Polychrome sync runtime error.
- Turned computer off ??Lights are still up even when S5 in UEFI is setup to turn everything off.
- Turned off the PSU manually, started computer ??no lights at all, Polychrome sync startup error. (Now I was thinking about motherboard RMA)

FIX:

Killed AsrPolychromeRGB.exe task, turn off the ASROCK connector in Razer Synapse 3 and rebooted the computer. After restart the Polychrome Sync started up and flashing firmware process started ??RGB lights are back.
So this is my experience so far. Now, I am waiting for some Beta Tester reward from you ASROCK. At least some contribution to all those ?RGB Compatible parts??would be nice! PLEASE FIX THIS!


Posted By: whoamikenken
Date Posted: 27 Jan 2020 at 5:13pm
Does anyone able to fix this?




Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net