Print Page | Close Window

UEFI M2 NVME boot hangs loading kernel on X399 MB

Printed From: ASRock.com
Category: Media&User's Review
Forum Name: AMD Motherboards
Forum Description: ASRock AMD Motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=11400
Printed Date: 24 Feb 2024 at 11:30pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: UEFI M2 NVME boot hangs loading kernel on X399 MB
Posted By: cfgauss
Subject: UEFI M2 NVME boot hangs loading kernel on X399 MB
Date Posted: 29 Apr 2019 at 8:06am
I have a ASRock X399 Professional Gaming MB and have filled all 3 NVME slots with Intel 660p M.2 2280 NVMes. I'm attempting to install Gentoo Linux using NVMes only. The MB recognizes the NVMes and I have no trouble partitioning them (gpt/UEFI) according to the Gentoo Handbook. I've created an LVM volume from the last partition of the first NVMe and the remaining two NVMes which I intend to mount as root. Grub does boot from the /boot partition on the first NVMe and hangs when loading the kernel. No diagnostic info appears on the framebuffer console.

I'm trying to determine if the problem is with the NVMes (the MB can't boot from this brand of NVMe) or the grub/Gentoo/software side.

Many thanks for any insights.



Replies:
Posted By: cfgauss
Date Posted: 30 Apr 2019 at 6:30am
The box does boot from the NVMe /boot partition and does load the LVM volume composed of NVMes. The problem was in grub2/kernel configuration. Details are at http://bit.ly/2GRNGyr.



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net