Print Page | Close Window

B450 Gaming K4 Memory Issue

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 27 May 2024 at 2:34am
Software Version: Web Wiz Forums 12.04 -

Topic: B450 Gaming K4 Memory Issue
Posted By: 4000xt
Subject: B450 Gaming K4 Memory Issue
Date Posted: 25 May 2019 at 12:34am

Looking for some help on an issue with a new build.

Checked out what type of memory was supposed for the B450 Gaming K4.
Decided on the G Skill:
G.Skill     2400     2400     8GB     F4-2400C15D-16GFT
Ordered the 16GB package of 2x8GB

Was having Windows crashing issues off the get go even during the Windows install.

Which I thought was a memory issue.

After getting Windows installed and getting boot up with both sticks installed I ran the Windows memory test and it did not find any issues with the memory.

I upgraded the BIOS to current P3.20 this helped some but still having windows crashing.

I tried installing the memory in different slots with the same results.

I finally put in one stick and that worked fine. Tried the other stick and that worked fine so if I am only using one at a time they both with fine.

If I try and run with them both installed that is when I am having issues.

Any help on this would be great.

Posted By: xhue
Date Posted: 25 May 2019 at 12:48am
Install both RAM sticks in A2/B2 memory slots. Make sure they are well-seated!

Check all power cables too.

Reset CMOS and re-install Windows from scratch.

If you still get crashes after you did all of the above, your mobo most likely is a dud (ad both RAM sticks work fine solo).

Posted By: 4000xt
Date Posted: 25 May 2019 at 1:18am
Thanks for the advice.

Had them both installed in A2/B2 but will give it another try only thing I did not do here is clear the cmos.

I will try that and see what happen. Not home for a couple more hours though.

One question after doing the cmos clear should I reset the UEFI to to defaults? To note also I have not changed any settings to the BIOS.

Except when installing Windows I changed the boot sequence to be the USB drive first as that is where I was installing from.

Thanks for the reply.

Posted By: xhue
Date Posted: 25 May 2019 at 1:48am
Clearing the CMOS should revert all UEFI settings to their default values, so no additional steps are needed here.

There is also no need to change boot order in UEFI. You can launch boot override with F2 (or whatever F-key are ASRock using for that).

After you verify Windows can install and run fine, you can go in UEFI and tune XMP for example. Please note that if you want SecureBoot you may need to re-install Win with that option enabled in advance. AFAIK ASRock mobos have SecureBoot disabled by default (go figure).

Then main goal here is to see if Windows will work well with the default settings.

Posted By: 4000xt
Date Posted: 25 May 2019 at 6:31am
Hi xhue,

I did the clear cmos settings as requested.

Installed memory in A2/B2 booted up fine with Windows install.

My Son played a game for about 27 minutes before it crashed.

Back to the single stick as he was playing on it for 3 hours this afternoon before I got home and worked fine that entire time.

Is there anything else I can do here?

Also to get a replacement should I work with ASRock or where I purchased it newegg.

Thanks for the help.

Posted By: 4000xt
Date Posted: 25 May 2019 at 7:42am
Just found out that since the mother board was ordered in march i cannot return to newegg so I filled out the form on the ASRock website.

Hopefully will not take long to hear back.

Posted By: xhue
Date Posted: 25 May 2019 at 3:29pm
Yeah, looks like a bad mobo.

Let's hope ASRock replace it. Another way is ebay or craigslist.

Posted By: 4000xt
Date Posted: 25 May 2019 at 8:47pm
I would hope so the mobo just came out of the box this week for a fresh install.

Posted By: Xaltar
Date Posted: 25 May 2019 at 11:31pm
Ordinarily I would suspect RAM compatibility but you have a Fortis kit (designed for AMD specifically) so that is unlikely if both modules work without issue solo. It technically could be the RAM having an issue, specific to dual channel operation. I would test both modules in slots A1 and A2 (single channel), if both modules work fine together in single channel then return the RAM. If not, return the board. When dealing with returns always deal with the place of purchase unless you are unable.


Posted By: 4000xt
Date Posted: 26 May 2019 at 4:27am
Thanks for the reply Xaltar.

I have tried the memory in every slot configuration that I can come with.

Still having Windows crashing.

Also the mobo was ordered from newegg in March so when I login now says not able to return.

The parts were ordered over time then when I got the memory this week I assembled everything and now at this point.

I could get a hold of newegg and see when they say about it.

I have also opened an incident with ASRock maybe they will have some other info. Or a piece of software I can run that will find something.

Thanks again for the reply.

Posted By: 4000xt
Date Posted: 30 May 2019 at 8:16pm
ASRock tech support got back to me and said it is likely a bad chipset on the motherboard and told me customer service would get in touch with an RMA. Just wanted to post a follow up.

Posted By: xhue
Date Posted: 30 May 2019 at 8:57pm

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -