Print Page | Close Window

Z97x killer USB woes?

Printed From: ASRock.com
Category: Technical Support
Forum Name: Intel Motherboards
Forum Description: Question about ASRock Intel Motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=116
Printed Date: 20 Apr 2024 at 6:21am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Z97x killer USB woes?
Posted By: Gabkicks
Subject: Z97x killer USB woes?
Date Posted: 10 May 2015 at 11:38am
It seems like if I plug a usb device into a certain port (maybe ports) on the back of my computer/mobo, they will sometimes stop working . I'm unsure of if this is some powersaving "feature" shutting down devices at the wrong time or if my motherboard is faulty or what.



Replies:
Posted By: parsec
Date Posted: 12 May 2015 at 1:36am
Your board has two USB 3.0 chips/sources, the Intel Z97 chipset and an ASMedia ASM1042AE. Each has its own driver. If you use Win 7, both drivers must be installed. Win 8/8.1 has a native USB 3.0 driver that is automatically installed, but the ASMedia USB 3.0 ports may work better with its own driver. We don't know what OS you are using.

The USB 2.0 ports are supplied by the Z97 chipset.

Windows 8/8.1 has an option in Device Manager for USB Root Hubs, in the Properties, Power Management tab, that can turn off power to a device to save power. It is enabled by default. Win 7 may have this option too.

What USB devices stop working?



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net