Print Page | Close Window

Help with disabling SMT

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: http://forum.asrock.com/forum_posts.asp?TID=11614
Printed Date: 28 Feb 2024 at 8:22pm
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Help with disabling SMT
Posted By: ZIZOX
Subject: Help with disabling SMT
Date Posted: 06 Jun 2019 at 3:42am
Hello forum users))
I encountered the following problem:
I can not disable SMT on the Asrock x470 Gaming K4 motherboard. I select smt-disable But after saving the settings and rebooting into windows it continues to work
I have flashed the latest BIOS for my motherboard 3.31 but this did not help (


PS.Please forgive my bad english
PPS.CPU is R7 2700



Replies:
Posted By: xhue
Date Posted: 06 Jun 2019 at 3:46am
OK, I honestly don't know how to achieve this with your board, but let me ask you - why you want that in first place?


Posted By: ZIZOX
Date Posted: 06 Jun 2019 at 3:50am
Well, I would like my motherboard to fully function and not partially.


Posted By: xhue
Date Posted: 06 Jun 2019 at 4:00am
Originally posted by ZIZOX ZIZOX wrote:

Well, I would like my motherboard to fully function and not partially.


In order to do that you need to ENABLE SMT, not disable it.


Posted By: ZIZOX
Date Posted: 06 Jun 2019 at 4:14am
One question, do you understand what smt is? And that the functionality of a normal MB allows you to disable it? It doesn?t matter why it?s not important, but what?s important is that I cannot use the functionality provided by the motherboard.



Posted By: xhue
Date Posted: 06 Jun 2019 at 4:32am
Yes, believe I've glimpsed the ways and doings of SMT, that much I can guarantee you.

As for why you can't disable it on your mobo, I have no idea. You could also raise a ticket with ASRock's support crew. On rare occasions they can be helpful too.


Posted By: Ray62
Date Posted: 06 Jun 2019 at 6:14am
And after changing SMT to disabled, saving settings, restart and going to the bios again (without starting an OS) it is still enabled?

If yes, this is a bios issue and a ticket for ASRock's support crew.




-------------
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE


Posted By: Ray62
Date Posted: 06 Jun 2019 at 6:27am
Hmm, you should do one test:
The following procedure is known for switching SMT on for some mainboards. Maybe it helps here for switching off too:

Go to the bios, disable SMT, save it and make a power cycle (switch power supply completely off, unplug, wait a minute, plug, switch it on and start the machine again into bios.

If it is still enabled, it is a real issue.


-------------
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE


Posted By: Ray62
Date Posted: 06 Jun 2019 at 3:56pm
There is another aspect for Ryzen CPUs: Suspend to RAM does only work, if SMT is enabled. So if Suspend to RAM is enabled, SMT maybe cannot be disabled due to this dependency (in this bios).
Meaning: Check that Suspend to RAM is also disabled when disabling SMT.

-------------
Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE


Posted By: 0C_Monk3y
Date Posted: 15 Dec 2019 at 11:54am
Confirmed broken on latest BIOS, Asrock needs to get basic features working. Severely limits overclocking on sub-zero temps... Its a useful feature, that's why its in there in the first place, please fix.

This is not an issue on older BIOS, but I'm fairly certain we can't roll back to prior agessa updates. Asrock disabled an important functionality advertised with the board, I'd suggest fixing it (or hand out refunds so we can go with other brands that work). X370 Fatal1ty.

-------------
"If its not icing over, then you're not overclocking!"


Posted By: 0C_Monk3y
Date Posted: 15 Dec 2019 at 12:48pm
Wohoo! They fixed it!

I put the wrong USB in when I said I had the latest (that one had my BIOS updates for my Asrock X399 board, not the X370). Haha, no wonder it didn't update and said it was the newest. The BIOS you have is indeed defective (I know this feature was broken since at least April of 2019, but version 5.5 fixed its issue with SMT enable/disable). Unfortunately now the BIOS looks like some static pixelated garbage instead of the cool looking red classic/original one, so that's kind of annoying, but you at least know its updated.

Due note, this BIOS specifically says "ASRock do NOT recommend updating this BIOS if Pinnacle, Raven, Summit or Bristol Ridge CPU is being used on your system." so who knows if my 2200g is going to work anymore but my 1700 is working fine from looking at the thread count, hopefully I can overclock higher (for games that only run on 8 threads and single GPU I use my testbench, otherwise its Threadripper and quad Xfire for most).

Performance comparison at 4.2 Ghz:
16 threads gave me 1800cb R15
8 threads gave me 1301cb R15
So hopefully I can hit a bit higher frequency with the lower temp since my chip is super picky about temp for stabililty (and trash overclocking). Beyond 15c core temp adding voltage is just bad and makes it unstable. Crossing the voltage vs temp stability curve, colder is better than more voltage)

Good luck!

-------------
"If its not icing over, then you're not overclocking!"



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net