Print Page | Close Window

Update BIOS Taichi x470

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=11913
Printed Date: 25 Jun 2024 at 4:26am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: Update BIOS Taichi x470
Posted By: butchboy
Subject: Update BIOS Taichi x470
Date Posted: 17 Jul 2019 at 2:59am
I am coming from an Intel build to AMD and am assuming I will need to update the Taichi x470 bios for my Ryzen Gen 3 CPU. I plan on grabbing from eBay, an Athlon 200G or A6-9500 so I can initially boot the board. I am waiting for my board to arrive. Here are the steps I plan on taking, though I am not sure if they are correct.

1) Download the BIOS v2.0 and the latest version onto a USB drive. 2) Using the old cpu, boot into windows and update the "AMD all in 1 with vga driver". 3) Reboot into UEFI and update BIOS to V2.0 if the current version is earlier. 4) Reboot into UEFI again and update BIOS to latest version.

Am I making this more complicated than it needs to be?   Thanks



Replies:
Posted By: dgtlntt
Date Posted: 17 Jul 2019 at 3:40am
Hi pipl!

I am in similar situation and my x470 taichi came today.
I got A6 9500 for initial bios update but have a problem

I haven't eaven installed windows and went on by updating to bios 2.00. it went smoothly.
After that i tryed updating to 3.43 but bios cannot see those files on USB stick. I have tried putting all bios files on usb and instant flash only sees 2.00

Why can't I update bios further?

Please help... :(

I think i need newer cpu to update beyond 2.00, I'll try with some other chip tomorow and keep you posted

For now don't try bios updates on A6-9500


Posted By: Eugeny44
Date Posted: 17 Jul 2019 at 6:50pm
I would not hold my breath, I have updated bios but asrock x470 itx is not working with 3000 ryzens.


Posted By: gizmic
Date Posted: 17 Jul 2019 at 8:20pm
give 3.46 a try

-------------


Posted By: dgtlntt
Date Posted: 17 Jul 2019 at 9:01pm
It is done!

i managed to come by a R3 2200G and with it installed all bioses showed up and 3.43 installed without a hitch.

after that i popped in my R5 3600X and after a few cicles it started normaly and i am now installing drivers in windows as i am typing this in separate window.

you don't need all that driver install nonsense from AsRock Bios page if you are doing a clean install anyway, that is only needed if you are upgrading CPU only on already existing system. But if you are upgrading it is better to start from scratch anyway.

so for anybody that went with taichi X470 for their Ryzen 3000 build the conclusion is this:

YOU NEED RYZEN CPU to update to latest BIOS! AT LEAST "R3 1200"! older CPUs are losing compatibility.
The board wont let you select a bios version if currently installed CPU is not in newer version compatibility list. (kinda nice trick actually)

That is all :)




Posted By: butchboy
Date Posted: 17 Jul 2019 at 9:44pm
I'm curious to know when you received your board and what BIOS version it came with. I am due to receive my board tomorrow. I am hoping to win the BIOS lottery and have v3.43 already installed.


Posted By: dgtlntt
Date Posted: 17 Jul 2019 at 9:59pm
Originally posted by butchboy butchboy wrote:

I'm curious to know when you received your board and what BIOS version it came with. I am due to receive my board tomorrow. I am hoping to win the BIOS lottery and have v3.43 already installed.


I had no such luck
Board came in yesterday
it has a small sticker over a bios chip saying 1.10 and so was the bios version
As i live in Eastern Europe i expected as much


Posted By: butchboy
Date Posted: 20 Jul 2019 at 4:50am
Oh so close! Just received my board from Newegg with version 3.20 on it. Have a Athlon 200GE on the way. Hopefully, by the time I put this together V3.46 will be available.


Posted By: butchboy
Date Posted: 24 Jul 2019 at 10:43am
Finally got all my hardware. Using a Athlon 200GE, I had no problems updating the bios to 3.43 and it booted right up. Haven't tested the stability or dimm speed yet, but so far so good.


Posted By: gizmic
Date Posted: 24 Jul 2019 at 11:12am
keep us updated i'm waiting for 3950X

-------------


Posted By: cx5
Date Posted: 24 Jul 2019 at 5:18pm
Originally posted by gizmic gizmic wrote:

keep us updated i'm waiting for 3950X


3950xxxxxxxxxxxxxxxx

what arrival date? I will visit here again to see your happiness :)

and I suppose x470 official get support pcie-4???? I forgot. I think it is.

-------------
x370taichi@3.50gen4
AX750 Optane900P SN770
3800x PosdonZro4 BarrowPWM-17w>420x140x28
XFX SWFT319 6900XT
MSI RX560 LP to get Fluid Motion BlueskyFRC 75hz


Posted By: gizmic
Date Posted: 24 Jul 2019 at 6:19pm
sept enough time to put coins in the piggy bank

i dont mind graphics pcie4 but i'm interested if the m.2 gets it i will migrate if sammy ever releases one

btw cx5 from 3200 1.20 bios i'm now on 3533 3.32 bios the struggle is real lol

-------------


Posted By: butchboy
Date Posted: 26 Jul 2019 at 10:00am
Just popped my system together.

MB: Taichi x470
Bios: v3.50
CPU: Ryzen 3700x
Memory: 2x Gskill F4-3200C16D-16GTZR
PSU: Corsair RMX 750
GPU: EVGA FTW GTX 1080
AIO: Corsair H115i Platinum
Case: Lian Li PC-011 Dynamic
SSD: Samsung EVO 500GB
HD: 2x WD Blue 4TB
Fans: 3x InWin Sirius Loop RGB 120mm

Everything went well until I tried to update "AMD ALL in 1 with VGA driver" from the Asrock App Shop. It totally borked my system. Couldn't even get into Windows with geting a BSOD. Even reinstalling Win 10 didn't fix it. I had to restore my SSD with a drive image to fix it.

Other than that, all is stable. However, I have my memory set really low at 2132 MHz. Just testing stability and board functions. Haven't tried using XMP yet, let alone severe overclocking or stressing.

Temps look good... about 34 or 35 at idle.

I will start pushing my system in the coming days.


Posted By: butchboy
Date Posted: 29 Jul 2019 at 11:34am
I cannot get my memory stable at 3200 MHz. Only stable at 2400 right now.   I have to work on the timings I guess. Rest of the system performs well however.


Posted By: cx5
Date Posted: 02 Aug 2019 at 3:02pm
Originally posted by gizmic gizmic wrote:

sept enough time to put coins in the piggy bank

i dont mind graphics pcie4 but i'm interested if the m.2 gets it i will migrate if sammy ever releases one

btw cx5 from 3200 1.20 bios i'm now on 3533 3.32 bios the struggle is real lol


WoW the "struggle is real" ....... IMC limit.......

I'm personally very anxious to try 3600mhz on 3000 IMC .......may be your ram will reach it.... no need to buy new...... so good.....

-------------
x370taichi@3.50gen4
AX750 Optane900P SN770
3800x PosdonZro4 BarrowPWM-17w>420x140x28
XFX SWFT319 6900XT
MSI RX560 LP to get Fluid Motion BlueskyFRC 75hz


Posted By: cx5
Date Posted: 02 Aug 2019 at 3:05pm
Originally posted by gizmic gizmic wrote:

i dont mind graphics pcie4 but i'm interested if the m.2 gets it i will migrate if sammy ever releases one


this one good???
https://www.amazon.com/Sabrent-Internal-Maximum-Performance-SB-ROCKET-NVMe4-2TB/dp/B07TKYWB3K/ref=sr_1_4?keywords=Sabrent%2Bnvme&qid=1562306327&s=gateway&sr=8-4&th=1

haih, on another note, I see many x570 users says M.2 heatsink provided clash with market provided come together headsink,

haih, headache ..... our AMD PR internal alignment not clear enough to mnfr.

-------------
x370taichi@3.50gen4
AX750 Optane900P SN770
3800x PosdonZro4 BarrowPWM-17w>420x140x28
XFX SWFT319 6900XT
MSI RX560 LP to get Fluid Motion BlueskyFRC 75hz


Posted By: cx5
Date Posted: 02 Aug 2019 at 3:06pm
Originally posted by butchboy butchboy wrote:

I cannot get my memory stable at 3200 MHz. Only stable at 2400 right now.   I have to work on the timings I guess. Rest of the system performs well however.


Just curious, you are using thaiphoon and 1usmus's calculator right?

-------------
x370taichi@3.50gen4
AX750 Optane900P SN770
3800x PosdonZro4 BarrowPWM-17w>420x140x28
XFX SWFT319 6900XT
MSI RX560 LP to get Fluid Motion BlueskyFRC 75hz


Posted By: alatariell
Date Posted: 02 Aug 2019 at 4:20pm
Hi Butch,

I have thee same memory on my x470 Taichi ultimate. Bad news is the board compatibility for this memory is only 2933 speed. I managed to get it stable with the dram calculater....looking up my screenshot for you. These calculator settings are stable for over 2 weeks now in my pc. Thank god we have dram calaculator tool.

Uploaded the screenshot with settings for you: https://imgur.com/a/ltj3vnS


Posted By: gizmic
Date Posted: 02 Aug 2019 at 5:43pm
cx5 on 3000 series the target is 1900mhz uclk & fclk
dont really need to get a high rated b-die because better binned just means lower volts

any 3200 cl 14 will reach 4200mhz the question is on what voltage :P

-------------


Posted By: ToxicTears
Date Posted: 05 Aug 2019 at 3:51pm
I thought, it 3.50 will be better but not. I must get back to 3.46.
3.50 = just only XMP profile. Other setting does not boot.
3.46 beta = i can boot with 3800 CL14. Total stable is 3600 CL14 and without some problem.


Posted By: butchboy
Date Posted: 08 Aug 2019 at 11:24am
Updated to Bios v3.60 on my Taichi x470. Now I have a stable system simply using the XMP profile (16GB Gskill Trident Z 16CL). I still feel my CPU temps are a bit high (40'ish on idle using Ryzen Master), but it's workable right now. Everything else is at stock settings for the time being.

I think a bit more tinkering with the fan curves will help.


Posted By: ToxicTears
Date Posted: 09 Aug 2019 at 2:42am
3.60 is better for CPU, but i cant still use other setting for ram then XMP. I cant nothing with RAM. And latency is very high for CPU, 72ns with 3200CL14? Oh. Something wrong with XMP setting, but stable.


Posted By: cx5
Date Posted: 12 Aug 2019 at 11:29am
Originally posted by gizmic gizmic wrote:

cx5 on 3000 series the target is 1900mhz uclk & fclk
dont really need to get a high rated b-die because better binned just means lower volts

any 3200 cl 14 will reach 4200mhz the question is on what voltage :P


WoW, really!!! thanks for telling.

-------------
x370taichi@3.50gen4
AX750 Optane900P SN770
3800x PosdonZro4 BarrowPWM-17w>420x140x28
XFX SWFT319 6900XT
MSI RX560 LP to get Fluid Motion BlueskyFRC 75hz



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net