Print Page | Close Window

X570 Gaming Phantom 4 no ethernet detected win 10.

Printed From:
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
Printed Date: 20 May 2024 at 1:47am
Software Version: Web Wiz Forums 12.04 -

Topic: X570 Gaming Phantom 4 no ethernet detected win 10.
Posted By: Sixthsense
Subject: X570 Gaming Phantom 4 no ethernet detected win 10.
Date Posted: 30 Jul 2019 at 3:10pm

I having an issue with Ethernet (Intel i211at) not detected at all in the device manager under a new windows 10 install.
Multiple cable checked, change ports, still no go.
The Led lit up as solid orange and after 3-4 seconds is blinking.
When loading the Intel driver receiving a "No Intel(R) Adapters are present in this computer".
When I try loading the Intel drivers as Legacy, The drivers are installing but giving an error code 31 in device manager.

The only interesting thing happened, when I load defaults in bios after I seen an Item on "other devices" which was a maybe a Lan device as one of the details in properties was something like "Lan\root" if I remember well.
Then I deleted the item as drivers from Intel did not made any change to it, and did not picked up any driver automatically as well.
Since never appeared on the list again.

So far I only running on an usb wifi lan adapter.
Bios updated to the latest 1.30 this morning, still no go.

Any suggestion or help will be very appreciated.

Posted By: Ray62
Date Posted: 31 Jul 2019 at 2:29pm
You could check the following options in the bios like:
Advanced\AMD PBS\LAN Power Enable
Advanced\AMD CBS\XGBE Configuration Options
or other ethernet related options.

And test, if you you can get a connection in the Tool section for bios updates. (Do not make an update, just test if the bios can find images in the net for that)

And, did you use the newest windows driver from the intel site?

Asrock Fatal1ty X370 Professional Gaming Offline
Under test:
MSI X570_MEG_ACE | AMD Ryzen 9 3900X | Scythe Mugen5 | 2x16GB F4-3200C14D-32GTZ@3466 | ASUS GeForce GTX 1080 Ti FE

Posted By: Sixthsense
Date Posted: 31 Jul 2019 at 4:18pm
Hi Ray,

Thank you for coming back to me.
I will looking into it tonight, will let you know how it goes.

Many Thanks In advance.

Posted By: Sixthsense
Date Posted: 02 Aug 2019 at 6:07pm
Hi All,

Thank you for Ray for his kind help.

The Problem is solved now.

The Ethernet port shows in the device manager now.
In the Bios Deep sleep is Disabled as a default.
Once I enabled deep sleep chosen function "enabled s4 and s5 state", the computer after saving the bios the computer went to Deep Sleep. Not reacting on my Power button and peripherals at all.
I disconnected the power cord from PSU for 1 minute.
Then I was able to power up the system.
Instead login in just restarted the system and went to the Bios disabled the Deep Sleep again.
Restarted the system, logged into Windows.
The ethernet controller was in the device manager, updated the driver to the latest, plugged in the cable and I was on the net.

All works now fine.

Many Thanks once again.
Kind Regards

Posted By: toxilicious
Date Posted: 26 Aug 2019 at 7:13pm
Hi all,

unfortunately I am experiencing same issue on my x570m pro4 asrock. However I was not able to fix it even with the solution provided on this forum (when deepsleep activated, it would NOT go to deepsleep like said above for me)

Do you guys think it is going to be fixed in the future with new BIOS version or what is causing my PC to not see any Intel adaptors in device manager whatsoever :/

Cheers and thx for response

Posted By: Sixthsense
Date Posted: 26 Aug 2019 at 7:51pm

I faced the issue myself again as well..
My boys is 1.30
Make sure no wireless adapter is connected to your system.
Cables are connected ok as well between the router and the system.
Do a bios default.
Restart the system and go back to the bios.
Enable the deep sleep.
Save and exit.
Restart the system.
Instead login to the windows. Shut simply shut down the computer.
Unplugged you power cord from the back of the computer for 3-5 minutes.
Plug the cord back.
Turn on your system.
Log into windows.
Go into device manager>network adapters. The Intel 211AT pan chip should be picked up as default now.
If so, just update the drivers to the latest one from Intel website.
If still no go. I recommend to check phisycaly the lan port pins are ok as well.
Or you can leave the OSU plug a bit longer unplugged.

I hope it works for you.
It worked for me.
Kind Regards


Posted By: Sixthsense
Date Posted: 26 Aug 2019 at 7:54pm
Sorry for the grammar mistakes, I wrote this on the phone.

Posted By: toxilicious
Date Posted: 26 Aug 2019 at 10:23pm
Hey 6thsense,

actually your detailed guide did fix it- hands down, WOW ! :D
I hope that is it going to stay like that.

Have a great one & Cheers,

Posted By: umb
Date Posted: 26 Aug 2019 at 11:22pm
Sooo i'm having this problem too.
i have the x570 phantom 4 with a ryzen 5 3600x
I cant' find a way to get this damn ethernet adaptor.
in the bios (1.40) i don't have any lan options.
i enabled the deep sleep in s4 and s5, nothing
i don't know else to do.

Posted By: toxilicious
Date Posted: 26 Aug 2019 at 11:54pm

I was not able to fix that for almost a day but then I have followed the exact way that 6thsense described - that fixed it !


Posted By: umb
Date Posted: 27 Aug 2019 at 12:57am
So I was able to fix the lab problem but... Now windows 10 is freezing. Some bsod screen. One related with afd.sys others a critical process died. Any hint?

Posted By: toxilicious
Date Posted: 27 Aug 2019 at 10:07pm
UPDATE: I came from work today and again no Intel Adaptor present in Device manager.

However after going again through 6thsense procedure - fixed again :)


Posted By: Race
Date Posted: 11 Sep 2019 at 3:50pm
Somehow weaved here from google searches and just wanted to thank sixthsense for the steps.

It actually failed the first time, but I was in windows pre-install steps, so maybe that didn't count? I completed the install and repeated the steps and bingo!

I'm also on bios 1.8, so sixthsense's solution still works here (and not by the bios update..)

Posted By: elendur
Date Posted: 17 Sep 2019 at 9:01am
Got here from google searches as well, and thank you sixthsense! This solution has worked for me temporarily, but after 10-15 restarts, I need to go through the procedure again. Any idea what the underlying problem is, and if there is a more permanent solution?

Posted By: Cookielessman
Date Posted: 14 Nov 2019 at 1:43am
Originally posted by elendur elendur wrote:

Got here from google searches as well, and thank you sixthsense! This solution has worked for me temporarily, but after 10-15 restarts, I need to go through the procedure again. Any idea what the underlying problem is, and if there is a more permanent solution?

I am in a similar boat here anyword on whether or not new bios updates would fix this, or what the underlying cause is?

Posted By: Sixthsense
Date Posted: 03 Mar 2020 at 4:56am
Hi Lovely People,

Far as I know myself there are no permanent solution at the moment.
I am ended up here again searched my own solution as I went away for a few days and turned off the sockets let the router finally rest :-)
Guess what?????
No Ethernet port again.
Simple unplug the power cable from the PSU does not work in this case of course.
Defaulted the bios, does not even touched deep sleep, which is off by default.
Set my ram again 3200Mhz.(as default always goes back to 2133)
Restarted, still no go.
Then just unplug the cattle cable from the PSU for 30 sec.
Plugged back the cable and turned on the system, and the ethernet port appeared again.
I am still on bios 1.30, as I do not liked the fact the newer bios fix some issue with the boost clock but gives less fps on games according to a lots off people on the net.

Kind Reagards

Posted By: Sixthsense
Date Posted: 03 Mar 2020 at 5:12am

My bad, I am running actually at BIOS version 1.70

Kind Regards

Posted By: amuro
Date Posted: 14 Apr 2020 at 10:40pm
I've been using this mainboard for the last 4 months without any problem. Then yesterday this sh*t started and my Intel NIC adapter was not recognized anymore. I tried the PSU unplug thing but didn't work.

What worked for me:

- update BIOS to 2.50 (optional)

- reinstall Windows 10 and all drivers (optional)

- reset CMOS by removing the Battery for 10 Minutes (I don't have a cap for the CMOS Jumper)

After this everything seemed fine until this morning when I started my computer and my adapter was gone again! So basically it lasted yesterday for a few hours and today same problem.

That's what I did today:

- unplug PSU cable and switch the button from 1 to 0 waited a little bit and turned it on.
- also I switched some USB cables around

Now it's working again. I wonder for how long. I really hope ASrock can fix this issue soon with some driver updates. Also I suggest that we all submit tickets to ASrock to speed up this process. I already submitted a ticket.

Posted By: dukeofdummies
Date Posted: 19 Apr 2020 at 11:48am
I was running into an eerily similar issue, Intel didn't think I had LAN hardware and windows didn't think I had proper drivers.

I noticed in device manager however that I had wifi drivers... but no wifi module slotted into my motherboard, which struck me as odd. Why did THAT work and it didn't even exist?

You guys pointed me to the bios which showed the wifi slot as enabled. I disabled that and pulled power for 15 minutes... that fixed everything.

Wish I had found this post before I restored to factory settings on my PC though...

Posted By: Alfonso
Date Posted: 02 May 2020 at 6:28am
Same problem. Asrock X570 PRO4
Just installed.
LAN connected, activity display seam OK
But go to the BIOS and no ethernet info.
Load windows 2019 Server (and try also with MS HyperV). No Ethernet detection.
Try to force driver loading... No Ethernet Interface message.

After reading some posts on this forum
I tried to configure deep sleep but no luck
I tried to unplug power during some time, no luck
Finally I swapp my keyboard and mouse from frontal usb to back usb
At his moment I got ethernet info in the BIOS menu
But I till have problems configuring the driver in windows. (but now I see it in the BIOS)
Thanks for any suggestions

Posted By: eddsh0t
Date Posted: 06 May 2020 at 5:39am
Found this from google and registered just to say thanks to sixthsense for his detailed method, i followed it + i rearranged some of the usb devices when the the PSU was unplugged. lets see how long this lasts :D

Posted By: DANgerPwn
Date Posted: 02 Jun 2020 at 5:34am
After a day of trying to get this to work your fix did the job! Appreciate the post! Back to Pwning!!

Posted By: Deano
Date Posted: 03 Oct 2020 at 8:32pm
Hi please help.

How do I get to the deep sleep option in bios. Im complete novice.

I used this work around before but this time I cant find the deep sleep option in bios.

No idea as I did before hand and this worked. For some reason the Intel driver have vanished again.???

Posted By: applevingar
Date Posted: 15 Nov 2020 at 8:52pm
Had the same problem, Fix it, here is how and why,

It's a windows 10 driver problem.
How to Fix
1. download drive for the motherboard
2. update new drivers
3. now works,

The option you could use download driver on a different computer and put on a USB then port or use an internet wireless adapter.

All thank best.

Posted By: Johnnyboy
Date Posted: 16 Apr 2021 at 7:49am
Hi, trying to help my daughter.:) Just joined this form and this is my first attempt in using it...:)
We had a power outage and the next morning her machine had no connectivity.
Bottom line no Ethernet adapter in the device list.
Finally found this post and gave it a try.
First fun was we have UEFI instead of BIOS so all the info. in you list created extra fun trying to find some of the items you were referencing.
I could not find any reference to Lan in the uefi at all.
I did finally sort out how to reset it to default and found how to set the deep sleep per your instruction.
Powered off, unplugged and left for 10 min vs the 3-5.
Still no fix. Was late so powered off again, unplugged and left for the night. In the morning before I powered on I UNPLUGGED the Ethernet cable. You had mentioned in you list to ensure all the cables were plugged in.
Amazingly the adapter showed back up in the list, plugged the cable in and all was we thought. She turn the machine back off as was going to be gone for the day. When back home, same thing, no internet, adapter not in the devices network list.
NOTE:we I clicked "view hidden" it did show up but could do anything will it.
I tried again what I did in the morning, unplugged the network cable, powered back on and the adapter came alive. Plugged the cable in and were connected and its currently being used.
Question is now, and ideas what would be preventing the adapter to be recognized when the cable is plugged in?

Thanks in advance for the help.

Posted By: zzilB
Date Posted: 19 Apr 2021 at 2:01pm
just want to say that you are an absolute legend (person with the S avatar). i tried almost everything i could searching the web for 3 days. stumbling across this post fixed my issue. i don't ever thank people like this, in fact this is my first time writing in a forum like this. just wanted to say thank you for resolving my issue. had the same problem with my ethernet network adapter not showing. IT WORKS!!!

Posted By: ResetCMOS
Date Posted: 15 May 2021 at 9:28am
I tried a couple of things on this forum but the last thing I did was simply to reset the CMOS battery.

I tried to do the whole Disable/sleep enable deep sleep, unplug computer, remove all wireless connections, I had also tested that the ethernet cable worked so it was evident that the issue lied with my motherboard, ASRock Phantom Gaming 4 x570 (BIOS P1.30). I didn't see any LAN options and my WLAN Radio setting was enabled, disabling resulted in one of my monitors having some weird graphical issue.

After nothing working, I turned off my computer, unplugged the power, removed the CMOS battery, placed it in again, and turned on my computer. Ethernet functional again, with the Intel i211 Gigabit Network Connection listed under Network Adapters, and a stable connection to the internet.

I just wish it didn't cost me the 40 dollars that it will take to replace the side panel which I unfortunately shattered as one corner touched the ground. In any case, had to create this account just so that maybe if in the future I forget what I did, I can look back and find this solution that was what actually worked out for me in the end, since it's the second time I found myself in this very forum.

Just remove and reseat your CMOS battery

Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 -
Copyright ©2001-2021 Web Wiz Ltd. -