Print Page | Close Window

X570 Taichi: Thunderb 3 OK, but USB-C causes BSoD

Printed From: ASRock.com
Category: Technical Support
Forum Name: AMD Motherboards
Forum Description: Question about ASRock AMD motherboards
URL: https://forum.asrock.com/forum_posts.asp?TID=12076
Printed Date: 20 May 2024 at 2:39am
Software Version: Web Wiz Forums 12.04 - http://www.webwizforums.com


Topic: X570 Taichi: Thunderb 3 OK, but USB-C causes BSoD
Posted By: FLPPasRock
Subject: X570 Taichi: Thunderb 3 OK, but USB-C causes BSoD
Date Posted: 02 Aug 2019 at 6:22pm
Hi,

I hope I can get assistance troubleshooting this issue here. I KNOW it's not an supported configuration since I'm using EVIL Gigabyte GC-Titan Ridge Thunderbolt AICs with an ASRock motherboard.

The reaseon I'm doing this is because unfortunately the ASRock Thunderbolt 3 AIC only use the outdated first-generation Thunderbolt 3 chipset (Alpine Ridge) whereas the Gigabyte GC-Titan Ridge uses, as the product name suggests the second-generation Titan Ridge chipset. For me this is relevant since only Titan Ridge supports DisplayPort 1.4 connections which I'm actually using.

Configuration details:

- The X570 Taichi is running UEFI version 1.70A
- Gigabyte AIC installed in PCIe slot 5, USB 2.0 and TB Header cables are plugged in, also external mDP connections to GPU
- Thunderbolt is enabled in motherboard?s UEFI
- Using the latest versions of Win 10 1903 and the Thunderbolt drivers (1.41.648.4)


Additional details:

- 3700X, no overclocking
- 2 x 16 GiB Crucial ECC DDR4-2666
- GPU: Radeon Pro WX8200 in PCIe 1
- 0.5 m mDP-mDP (1.2) cables from GPU to TB AIC
- The TB3 AIC is very firmly installed, doesn?t jiggle at all when plugging a device into or unplugging it from its Type C ports
- The BSOD also appears when plugging an USB thumb drive into a connected USB hub so there is absolutely no mechanical stress on the TB3 AIC.
- Ethernet: Intel XL710 QDA2 in PCIe 3
- All devices including X570 chipset with latest publicly released drivers available at this time (chipset driver release from July 31st)


Issue description:

- The two Thunderbolt 3 Type C ports seem to work fine (tested various adapters, USB 3.1-SATA adapter, USB-C to 4 x Type A 10 Gbps USB hub) when the devices are connected when the system is still powered off

- When plugging an mere USB Type C device (not a Thunderbolt device) into or unplugging one from the TB3 type C ports I get a BSOD (WHEA_UNCORRECTABLE_ERROR)

- Thunderbolt works seemingly fine, however it only negotiates a 20 GbE networking link between the GC-Titan Ridge AIC and a Mac mini 2018 (also with Titan Ridge TB3 controller) with a 2.0 m Belkin TB 3 cable that is rated for 40 GbE/100 W (but without DisplayPort capability for some reason)

- So it seems the BSoD is caused whenever the Intel USB 3.1 controller built-into the TB3 AIC or DisplayPort Hotplugging comes into play


Things I've tried without any effect:

- Tested a second unit of the GC-Titan Ridge AIC

- Changed the internal motherboard header and power cables to the GC-Titan Ridge AIC

- Changed DP ports on the GPU that are connected to the GC-Titan Ridge AIC

- Newly installed Win 10 Pro 1903 on an erased SSD (and BIOS/MBR setup instead of UEFI)

- New AMD chipset drivers that came out July 31st

- Tried the more current AMD Radeon Consumer driver package instead of the enterprise one for the WX 8200

- Tried s different GPU (NVIDIA Quadro P2000, also with DP 1.4), same result

Any idea what?s causing this? I know that this is an unsupported configuration but I hope it can be fixed somehow.

Any help is greatly appreciated!



Replies:
Posted By: wilshing
Date Posted: 09 Aug 2019 at 6:36pm
It mentions below limitations on x570 taichi page. Even you us ASRock AIC, it will also has these issues.

I think for usb devices, you should avoid using ports on AIC.




https://www.asrock.com/mb/AMD/X570%20Taichi/

Thunderbolt 3 AIC Header
Thunderbolt 3 is no longer limited to certain chipset, ASRock is the first motherboard manufacturer to skillfully implement the Thunderbolt 3 technology onto AMD X570 motherboards. All you need is a Thunderbolt 3 AIC R2.0 card!
*1: Only three TB3 devices can be detected.
*2 : Some USB 3.2 Type-C devices will cause system reboot after wake up from S3/S4.
*3 : Cannot light up the TB3 monitor after wake up from S3/S4, re-plug the cable is needed.
*4 : Does not support Thunderbolt 3 PCIe graphics card box.
      


Posted By: Ryzentosh
Date Posted: 10 Aug 2019 at 3:17pm
Excellent post wilshing. Thank you for that.
It sounds like I may need to get a Titan Ridge card and try that out if that's the latest. Even if by Gigabyte.

I have a Gigabyte TB3 card new in box. I'll take a look and see if it is Titan ridge. If so I'll give it a shot next.

Was the cable pin compatible with the motherboard?

I'm surprised to hear that the Asrock card is not a Titan ridge. They have Rev2.0 out supposedly but I can't seem to find it online anywhere to buy. I wonder if that is newer and a Titan Ridge or will at least work.

I ended up buying the Asrock Thunderbolt AIC Rev 1.0 without knowing there even existed a 2.0 as I just read my motherboard manual and it didn't state I needed a Rev 2.0 AIC. So I thought I was good to go.

On the website now it lists all the new x570 boards EXCEPT my X570 Pro4. Weird. I wonder if this was an oversight? Or intentional?

I'm on bios 1.30 and now wonder if buying the Pro4 wasn't the value I thought it was?

Hope Asrock or someone with these answer reads this.

Thank you for your post.


https://www.asrock.com/mb/spec/product.us.asp?Model=Thunderbolt%203%20AIC%20R2.0

https://www.asrock.com/mb/spec/product.us.asp?Model=Thunderbolt%203%20AIC


-------------
Ryzentosh


Posted By: FLPPasRock
Date Posted: 12 Aug 2019 at 12:07am

Am kind of shocked by that limitations on the Overview page.

The sweet irony of this whole thing is that even Rev. 2.0 of ASRock's TB3 AIC does not have a current Titan Ridge TB3 chipset.

If its specifications page ( https://www.asrock.com/mb/spec/product.asp?Model=Thunderbolt%203%20AIC%20R2.0#Specification ) is correct it only uses an Intel JHL6540 chipset ( https://ark.intel.com/content/www/de/de/ark/products/94031/intel-jhl6540-thunderbolt-3-controller.html ) -nhooray for 3 year-old silicon :(

The Titan Ridge chipsets start with a 7, example:

https://ark.intel.com/content/www/us/en/ark/products/97400/intel-jhl7540-thunderbolt-3-controller.html

Hope that we can somehow get the Gigabyte GC-Titan Ridge AIC working. Gigabyte seems to have killed all efforts to bring TB to AMD systems, various motherboards do no longer sport the Thunderbolt Header in production runs whereas the early engineering/production revisions still had it on.

Don't quite understand why ASRock is treating this issue so subpar, with proper TB3 support on AMD platforms they would have an absolutely unique feature to advertise with until USB 4 comes around - and I personally don't want to wait till next year.


Posted By: Ryzentosh
Date Posted: 12 Aug 2019 at 8:16am
Thanks for that. I also figured out soon after that my Gigabyte card was the Raven Ridge and not the Titan Ridge. And also that the Rev 2.0 was still the same old chipset. It seems it just has the internal connectors to make it tidier for cable routing. Kinda lame of Asrock to not have the latest chipset out yet for a Rev 3.0 card...

But not to worry. :) I got it working!

See my post here: http://forum.asrock.com/forum_posts.asp?TID=12163&title=enabling-thunderbolt-support-for-aic-v10

I shared as much detail as I could on the process as it was long and convoluted. Hope this helps others.

-------------
Ryzentosh


Posted By: Ryzentosh
Date Posted: 12 Aug 2019 at 8:27am
So your TB header cable from the Gigabyte card was identical to the Asrock one pinout wise? Or were you able to use the Asrock header cable on the Gigabyte card?

And you got it to work you said for TB3? Just not USB? IF so, that's not so bad.

You also list you are using Thunderbolt drivers (1.41.648.4)? Where are you downloading those from? I thought mine were listed as 17. 4.78.500 or something like that. I had to grab those from Lenovo as I didn't find anyone else offering them for direct download. Haven't found them on Intel either. So am interested in a link if you have one. You may also want to try the Lenovo version to see if it allows it to work for you.

-------------
Ryzentosh


Posted By: FLPPasRock
Date Posted: 15 Aug 2019 at 12:42am
Yes, Thunderbolt 3 itself seems to work fine - as soon as USB 3.x and DisplayPort devices come into play with hotplugging the BSoDs appear. Both works fine when the devices are already connected to the AIC prior to powering on the system.

The Thunderbolt Headers on the motherboards between ASRock and Gigabyte are identical however you cannot use the cable of one manufacturer with the AIC of the other since the TB header on the AIC is shaped completely different.

The thought that maybe the TB Header causes the BSOD also crossed my mind but this is unlikely since it is only to toggle/enable/reset the Thunderbolt controller.


Posted By: FLPPasRock
Date Posted: 15 Aug 2019 at 12:45am
PS: The drivers I used are aavailable on the GC-Titan Ridge's support/download page, however it requires Windows 10 1903 to use that version. I also tried an older driver version but the BSoD issue remained unchanged.


Posted By: Decca
Date Posted: 12 Sep 2019 at 3:44am
Just fitted the ASRock AIC v2 card into my X570 Taichi, but cannot see anywhere in the BIOS v2.0 for the setting to enable thunderbolt.

Can anyone help please?


Posted By: Decca
Date Posted: 12 Sep 2019 at 4:31am
No worries - found it eventually, buried in menu options that I don't understand!


Posted By: skavan
Date Posted: 27 Sep 2019 at 11:01pm
Hi all,

Just found this thread -- after punching out a question on TB3 here:

http://forum.asrock.com/forum_posts.asp?TID=11976&PID=68346&title=ryzen-3000-series-support#68346

My x570 Creator Mobo has TB3 built in -- but teething problems (4K only, USB Hub issues).

Perhaps someone on this thread has a clue?

s.



Posted By: Casey_SJ
Date Posted: 28 Sep 2019 at 12:42am
I have the same X570 Creator with Windows 10 installed and Thunderbolt is working properly. My Thunderbolt 3 dock connects and all USB/Ethernet ports are functional.

Have you made the following changes in BIOS:

Advanced --> AMD PBS --> scroll all the way down. You will see:

1. Thunderbolt. Set this to Enable (which is the default anyway).
2. Security. Set this to "No Security".

Save and exit. See if this helps.

I have read that eGPUs are not supported, but external Thunderbolt 3 monitors should work,, including their on-board USB, camera, and sound devices.


Posted By: skavan
Date Posted: 28 Sep 2019 at 1:15am
Hi,

A fellow x570 creator owner! You may be a godsend.
Would you mind outlining you GFX card to Mobo to TB Out connections and also what brand/model of dock you are using...and finally do you go:

x570 TB ---> Dock ---> Monitor (4k or 5k?)

or are you using TB for peripherals, hence the dock?

I am trying to go:
RTX 2080Ti DP 1.4 ---> x570 DP In --> TB ---> 5K Monitor.

I will go buy one of your docks --- and stick that in the middle maybe.
RTX 2080Ti DP 1.4 ---> x570 DP In --> TB ---> TB Dock --> 5K Monitor.

s.


Posted By: Casey_SJ
Date Posted: 28 Sep 2019 at 2:05am
I'm using an OWC 14-Port Thunderbolt 3 Dock and a PowerColor Gaming Station eGPU with several USB ports in the eGPU chassis. However, I do not currently have a Thunderbolt monitor, but expect to get one soon.

Under Windows 10 I had no problem connecting the Dock and the eGPU, except that the GPU inside the external chassis did not work -- I expected this based on something I read about lack of eGPU support.

I have the PowerColor Red Devil AMD RX 580, which supports DP 1.4, but at this time I'm using a simple 1080p monitor. Once I move this new build into the home office, I'll connect it to a 4K DisplayPort monitor until I finally decide to get a 5K Thunderbolt Display.

In order to drive a Thunderbolt monitor, what you are doing right now is correct, namely:

RX 2080Ti --> X570 DP-In Port --> 5K Monitor (do not insert dock into this chain)

Of course, a USB-C cable won't work. It must be a Thunderbolt 3 cable with the lightning symbol on the ends.

You may also need to set "Security" to "No Security" in the Advanced --> AMD PBS section of BIOS Setup.

Have you installed the latest Thunderbolt drivers for Windows?


Posted By: Casey_SJ
Date Posted: 28 Sep 2019 at 2:09am
By the way, I think that the latest firmware (1.70) for the X570 Creator is still a bit buggy and/or unfinished. Will keep a lookout for updates.


Posted By: skavan
Date Posted: 28 Sep 2019 at 4:01am
Thanks so much.

- Am using Active TB3 cables everywhere
- When you say "Have you installed the latest TB3 drivers for windows"...well I have installed asrock's latest TB Stuff (17.4.77.400). Is that what you meant? Also did a device manager search for updates -- it came up empty.
- Finally, when you say don't insert a dock into this chain -- why not?


Posted By: Casey_SJ
Date Posted: 28 Sep 2019 at 5:48am
Inserting a dock adds another transmission/retransmission layer into the chain. If a Thunderbolt cable directly from the motherboard to the monitor does not work, then inserting a dock into the chain is not likely to solve the problem.

One can buy and use a Thunderbolt 3 dock without any problem, of course, but using the dock specifically as a solution for the Thunderbolt Display problem is most likely not warranted.

I think I downloaded a newer Thunderbolt driver from here -- version 17.4.78.500:
https://www.station-drivers.com/index.php?option=com_remository&Itemid=353&func=fileinfo&id=3774&lang=en


Posted By: L3V1A7H0N
Date Posted: 23 Nov 2019 at 12:31pm
https://photos.app.goo.gl/kDK9v73VXG2aKQAeA

It's under Advanced -> CPU Settings -> AMD PBS
And scroll WAAAAAYYYY to the bottom.

Took me forever to find it.

Just plugged in my brand new Apollo Twin X and it came right up. I'm also on the latest 2.50 bios update. Taichi 570x and ryzen 3900x. I'm using the Asrock Thunderbolt 3 AIC.

Good luck to anyone trying to get this to work. Took me a bit!


Posted By: justme
Date Posted: 20 Dec 2019 at 9:29am
I am in the process of building a ryzen 3600 and was looking at the different mobos that would support TB3 (Apollo Twin). Seems like a lot of people here have experience getting everything working. Thank you for posting all your issues and responses, as it has been fun to learn from you all.

I was looking at the Taichi 570x + the AIC but I am open to suggestions. Does anyone have any tips or suggestions for me before I order everything?

Also curious if the Taichi 570x will support TB3 through the Type C formfactor?


Posted By: justme
Date Posted: 20 Dec 2019 at 9:39am
Just wanted to also say I was really trying to weigh the differences between the ASRock X570 EXTREME4, Taichi and anything else you all may suggest.


Posted By: Ryzentosh
Date Posted: 20 Dec 2019 at 10:06am
I'll try and answer later when I have more time, but I would recommend getting a board that specifically lists it as supporting TB3 on their website like the higher end boards. Also, checking that it has enough expansion slots. My Pro4 doesn't have quite as many slots as the taichi or perhaps even the Extreme 4, so double check that.

I also haven't been able to get it to boot directly into MacOS without booting into Windows first. But I haven't tried again since the newer bios versions have come out. So it may work now. I know I updated to the latest beta bios, the one just prior to this latest official release and now both of my NVME drives appear in the list simultaneously whereas before they wouldn't. So that was nice to see. (Adata 8200 pro and Inland Premium, both 1tb nvme drives).

Also, I got an Apollo Arrow and it doesn't work at all last I tested it with the old bios.

But next on the list is to try again with everything on the new bios. Not soon probably though as I lack time.

Good luck.



-------------
Ryzentosh


Posted By: justme
Date Posted: 21 Dec 2019 at 2:19am
Hey, thank you so much. It looks like the Taichi is the best bet then. Honestly whichever one is going to be easiest for me to get working.

I also have the Adata 8200 pro, so that is nice to know that issue is fixed.

Keep me posted if you have any other ideas or how your build goes. I really appreciate it.


Posted By: justme
Date Posted: 25 Dec 2019 at 2:31pm
Update: I got the x570 Taichi and the Gigabyte Titan Ridge Card. My Apollo Twin status is connected which is awesome. So the Thunderbolt is working. However the UAD Software does not see my Apollo even though my computer does. The UAD Console reads "No Device Connected" even though the Thunderbolt Control Center reads the Apollo Twin as "Status: Connected"

Updated BIOS
Updated UAD Software
Updated Apollo Twin Firmware and Drivers
Updated Titan Ridge Drivers

Any suggestions would be much appreciated. My thoughts are, I am doing something that just isn't supported. I know there are other producer / PC builders on this forum so just curious what you all have found.


Posted By: justme
Date Posted: 27 Dec 2019 at 4:24am
Update 2: I got everything working. I have a ground loop somewhere but not too worried about that, should be able to solve it.

AMD Ryzen 5 3600
ASRock x570 Taichi
Gigabyte Titan Ridge Thunderbolt Add-in Card

Universal Audio Apollo Twin

Pretty happy.

Thanks everyone for posting on this forum. Ryzentosh, you were a huge help.


Posted By: DicusBarbavici
Date Posted: 01 Apr 2020 at 2:35am
What change did you make that got it working? Any advice.

I am trying to get Focusrite Clarett working on x570 Creator and after two days no luck so far.


Posted By: ThreeDee
Date Posted: 01 Apr 2020 at 4:28am
To OP .. have you tried updating to latest greatest BIOS and see if that helps with USB-C BSOD's?

-------------
|Ryzen 5 5900|ASRock X570 Taichi-BIOS 4.60|2x16GB HyperX Predator RGB 3200@3600 1:1 IF|ASRock RX 6700XT|2 x PCIe 4.0 M.2 Drives for OS & Games|850 WTT Seasonic 80+ Titanium PSU|Noctua NH-D15|


Posted By: magentosh
Date Posted: 29 May 2020 at 2:33am
Ha, I stumbled upon you in Reddit and now ASRock forums.

Did you get your X570 Creator working for TB2?

I have an Apollo Twin and am migrating of mac, like a lot of people. X570 Creator appears to be the preferred config.

Thanks



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.04 - http://www.webwizforums.com
Copyright ©2001-2021 Web Wiz Ltd. - https://www.webwiz.net